The default bug view has changed. See this FAQ.

'perspective' property doesn't reject negative numbers

RESOLVED FIXED in mozilla13

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: ayg, Assigned: ayg)

Tracking

Trunk
mozilla13
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [inbound])

Attachments

(1 attachment)

Bug 505115 part 18 fixed this for the perspective() function, but not for the 'perspective' property.
Created attachment 595117 [details] [diff] [review]
Patch

Mochitests in layout/style/test/ all pass on my machine.  Didn't push to tryservers because my account hasn't been created yet.
Attachment #595117 - Flags: review?(matt.woodrow)
Attachment #595117 - Flags: review?(matt.woodrow) → review+
Keywords: checkin-needed
Keywords: checkin-needed
Whiteboard: [autoland]

Updated

5 years ago
Whiteboard: [autoland] → [autoland-in-queue]

Comment 2

5 years ago
Autoland Patchset:
	Patches: 595117
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/rev/8472b2cb12d8
Try run started, revision 8472b2cb12d8. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=8472b2cb12d8

Comment 3

5 years ago
Try run for 8472b2cb12d8 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=8472b2cb12d8
Results (out of 210 total builds):
    success: 183
    warnings: 20
    other: 7
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-8472b2cb12d8
 Timed out after 06 hours without completing.

Updated

5 years ago
Whiteboard: [autoland-in-queue]
All the failures look unrelated -- some are filed as intermittent failures, and some memory leaks on Win debug.  And a timeout on Android opt C1.
Keywords: checkin-needed

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/3bcf2388db18
Keywords: checkin-needed
Whiteboard: [inbound]
https://hg.mozilla.org/mozilla-central/rev/3bcf2388db18
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Duplicate of this bug: 696936
You need to log in before you can comment on or make changes to this bug.