ClapClap app keeps pinging for clapclap.ogg, which is a 404

RESOLVED FIXED

Status

Infrastructure & Operations
Telecom
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: stephend, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
The ClapClap app [1] keeps looking for an OGG file that doesn't seem to be there:

[15:31:36.424] GET https://icecast.mozilla.org/clapclap.ogg [HTTP/1.0 404 File Not Found 470ms]

[1] https://ringring.office.mozilla.org/clapclap/
Uh, that file isn't even in SVN: http://viewvc.svn.mozilla.org/vc/projects/clapclap/trunk/ :(
clapclap doesn't run on icecast.mozilla.org. :)

The current version of clapclap routes the user-end of the call it places to an icecast stream and attempts to load that stream in the browser, instead of requiring a phone number for the server to call the user at.  This way the user hears the call progress directly in their browser instead of needing to be at a phone.

That the file is coming up 404 means the icecast server rejected the broadcaster probably.  It's likely the firewall hole for it got revoked at some point when the air mozilla stuff was removed from icecast or something.

I'll investigate.
Assignee: nobody → justdave
Component: Webdev → Server Operations: Telecom
QA Contact: webdev → mrz
I can't reproduce this.  The icecast URL seems to be working fine for me when I use clapclap.  It does come up as a 404 if clapclap doesn't connect for some reason when it places the call...
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

6 years ago
Well, I can, immediately upon opening the app:

http://screencast.com/t/4YRTztXuX
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The icecast server it connects to is no longer there.  Best solution is probably a local icecast server on ringring.
Depends on: 926273
And done.  This is working again now, other than the fact that the call-in number for this has been busy for the last 20 minutes and it apparently doesn't detect and handle busy properly (no indication in the browser window except by listening and hearing the busy tone).
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → FIXED
I filed bug 926442 for tracking the busy-handling problem.

Updated

4 years ago
QA Contact: mzeier → adam
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.