Closed Bug 725171 Opened 9 years ago Closed 9 years ago

Context menu is broken on bookmarks on the awesome screen

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 13
Tracking Status
firefox13 --- verified

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

(Keywords: regression)

Attachments

(1 file)

Regression caused by bug 716918. I'm working on a patch now.
Attached patch patchSplinter Review
The new bookmarks list is an ExpandableListView, but unlike the history list, it is backed by a CursorAdapter, so we still want to get a Cursor. I moved around the logic a bit to try to make this as clean as possible. (I also cleaned up some of the type casting that's going on in here.)
Attachment #595263 - Flags: review?(wjohnston)
I should note that onContextItemSelected doesn't need updating, since it already correctly handles items that are Cursors or Maps.
Attachment #595263 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/824245ea0555
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Comment on attachment 595263 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 716918 (not uplifted yet)
User impact if declined: we need this in order to uplift bug 716918
Testing completed (on m-c, etc.): landed on m-c
Attachment #595263 - Flags: approval-mozilla-beta?
Attachment #595263 - Flags: approval-mozilla-aurora?
Comment on attachment 595263 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #595263 - Flags: approval-mozilla-beta?
Attachment #595263 - Flags: approval-mozilla-beta+
Attachment #595263 - Flags: approval-mozilla-aurora?
Attachment #595263 - Flags: approval-mozilla-aurora+
Comment on attachment 595263 [details] [diff] [review]
patch

Clearing approval for Aurora 12 and Beta 11 because we are not currently planning a Native Fennec release of these versions.  If this changes in the future, we will likely do a mass uplift of all native fennec changes.  For now, let's get these bugs off the channel triage radar.

[Filter on the string "mbrubeck-bugspam" if you want to delete all of these emails at once.]
Attachment #595263 - Flags: approval-mozilla-beta+
Attachment #595263 - Flags: approval-mozilla-aurora+
Verified fixed on:

Firefox 13.0a1 (2012-03-05)
20120305031045
http://hg.mozilla.org/mozilla-central/rev/433cfbd2a0da

--
Device: HTC Desire
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.