Closed Bug 725189 Opened 10 years ago Closed 9 years ago

[Page Thumbnails] don't save thumbnails for https or pages behind login

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 755996

People

(Reporter: raccettura, Unassigned)

References

Details

Attachments

(1 file)

Attached image Facebook Thumbnail
Just a theory, memorializing webpages viewed with a thumbnail may not be ideal for the same things that use SSL and/or are behind a login (perhaps utilize password manager to know when that is as it does a decent job).  

For example someone's facebook photos may not be ideal… it's an information leak.
I guess it's worth noting thumbnail service came via bug 497543 and uses disk cache AFAIK.
Can I suggest they use the favicon or SOMETHING instead. I was just going to file a bug saying that none of my pages have thumbnails but it turns out all of them are behind logins.
wrong component.
Component: Places → General
Product: Toolkit → Firefox
QA Contact: places → general
Blocks: 497543
OS: Mac OS X → All
Hardware: x86 → All
Summary: moz-page-thumb shouldn't save thumbnails for https or pages behind login → [Page Thumbnails] don't save thumbnails for https or pages behind login
Perhaps the best solution is to simply honor robots.txt.
I'm not sure if its to do with the login. 
Instead I think its to do with pages that auto update without a refresh.
AJAX maybe screwing up the thumbnail creator ?

Just wondering.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755996
You need to log in before you can comment on or make changes to this bug.