Extension incompatible with Firefox10

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
6 years ago
4 months ago

People

(Reporter: Rex, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20110504 Firefox/4.0.1
Build ID: 20110504035914

Steps to reproduce:

We are upgrading our pluging to support firefox 10. We compiled XPT using the gecko 10 and we update the chorome.manifest & install rdf file accordingly so that it support for firefox 10.


Actual results:

We have older version of firefox in our test machine and we try to install the firefox 10 by using the Firefox 10.0 installer and it complaint that our plugin in is not compatible with Firefox 10. We uninstall Firefox 10 and reinstall it again will have the same compatibility issue. At last we try to uninstall Firefox 10 and check "Remove my Firefox personal data and customization" along the un-installation wizard, then we reinstall the Firefox 10 again and this time it work.

We run the similar test on another test machine and this time we upgrade to firefox 10 thru “Help->About Mozilla firefox->Check for updates" and our plugin work accordingly in Firefox 10.


Expected results:

Upgrade to Firefox 10 thru Firefox's Updater or installer should have the same expected result. In our case, it seem that installing thru installer (EXE) will somehow trigger incompatibility issue.
(Reporter)

Updated

6 years ago
Severity: normal → critical
Version: 4.0 Branch → unspecified
(Reporter)

Updated

6 years ago
Component: Untriaged → Extension Compatibility
Is this a NPAPI plugin (example: flash, java) or extension (example: adblock) ?
You use the term "plugin" and the XPT extension but it's new to me that plugins can be reported as incompatible.
Severity: critical → normal
(Reporter)

Updated

6 years ago
Summary: Plugin incompatible with Firefox10 → Extension incompatible with Firefox10
(Reporter)

Comment 2

6 years ago
It's extension not plugin :)
Component: Extension Compatibility → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: untriaged → add-ons.manager
(In reply to Rex from comment #0)
> We have older version of firefox in our test machine and we try to install
> the firefox 10 by using the Firefox 10.0 installer and it complaint that our
> plugin in is not compatible with Firefox 10.

How did it complain? Some dialog, or something else?

Are you still able to reproduce this problem in any way?
(Reporter)

Comment 4

6 years ago
I can reproduce this easily. I've more precise steps to reproduce this now. 
I've Firefox 3.6.12 installed and never launch it before.
Here we go the scenarios to reproduce the issue.

Scenario 1 (extension incompatible):
1. Don't launch the firefox 3.6.12 
2. Upgrade our extension to support Firefox10
3. Install Firefox 10.0.exe
4. Observed that Firefox setup required to reboot the system (see attached image FF10_Reboot.png)
5. After reboot the system, launch Firefox 10
6. Choose our extension from the "Select Your Add-ons" windows
7. Observed that the Select your Add-ons windows displayed this message
   "The following add-ons are disabled, but will be enabled as soon as they are compatible" (See attach image FF10_Addons.png)
8. After Firefox 10 launch completely, observed that our extension is not available.
9. I check the Add-ons Manager page and it complain that the extension is incompatible with Firefox 10

Scenario 2 (extension compatible):
1. Launch the firefox 3.6.12 at least once
2. Upgrade our extension to support Firefox10
3. Install Firefox 10.0.exe
4. Observed that Firefox setup doesn't required to reboot the system (see attached image FF10_Launch.png)
5. Launch Firefox 10
6. Choose our extension from the "Select Your Add-ons" windows
8. After Firefox 10 launch completely, observed that our extension is available and working correctly.
9. I check the Add-ons Manager page and it doesn't complain that the extension is incompatible with Firefox 10
(Reporter)

Comment 5

6 years ago
Created attachment 595618 [details]
Firefox 10 setup reqired system reboot
(Reporter)

Comment 6

6 years ago
Created attachment 595619 [details]
Firefox 10 setup doesn't required system reboot
(Reporter)

Comment 7

6 years ago
Created attachment 595620 [details]
Firefox 10 Select your Add-ons windows
Where can we get your extension for testing?
(Reporter)

Comment 9

6 years ago
Created attachment 596224 [details]
Update.zip
(Reporter)

Comment 10

6 years ago
you may try the following:

1. You can download the fs2011 trial version @ http://download.f-secure.com/estore/fs2011.exe
2. Run fs2011.exe and click next to use the default setting in the setup wizard
3. Skip to install Parental Control browsing mode by clicking the "Skip" button
4. Downloading of updated will begin now in order to complete the installation (this will take some time) :)
5. Download & extract the attached update.zip (find it in the attachment list in this case) to your local folder
6. Run the following command to update the product so that it support firefox 10.
   litmus-update-handler.exe testing_install <update folder path\litmus-update.dat> 5673 <update folder path>
7. The command should return "Status 1" in case it successfully patch the update

BTW, i am not sure how to configure so that firefox setup require to reboot. Anyway, we have 2 different profile created for older version of firefox.

Updated

3 years ago
Keywords: qawanted

Comment 11

4 months ago
With Firefox 57 only WebExtensions are valid with Firefox. There has been 5 years since the last comment on this bug, so closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.