Closed Bug 725279 Opened 9 years ago Closed 9 years ago

crash @ mozilla::plugins::PluginInstanceParent::~PluginInstanceParent with Flashblock

Categories

(Core :: Plug-ins, defect)

13 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 723473

People

(Reporter: jmjjeffery, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-79c7c27a-e51b-4d21-87c6-a9f352120208 .
============================================================= 

I've had this 6 times.  Sometimes during site navigation, www.msnbc.com mainly.  Also most are occuring overnight when I'm sleeping and browser is minimized to taskbar.  

This started I believe after the landing of:
https://bugzilla.mozilla.org/show_bug.cgi?id=90268

Win7 x64, m-c nightly builds.
Addons: Flashblock, Console2, ForecastFox
Flash beta:  11.2.202.197
Component: Untriaged → Plug-ins
Product: Firefox → Core
QA Contact: untriaged → plugins
It first appeared in 13.a1/20120201.

All crash reports have Flashblock installed.

Signature 	mozilla::plugins::PluginInstanceParent::~PluginInstanceParent() More Reports Search
UUID	79c7c27a-e51b-4d21-87c6-a9f352120208
Date Processed	2012-02-08 13:02:48
Uptime	3888
Last Crash	6.9 hours before submission
Install Age	22.3 hours since version was first installed.
Install Time	2012-02-07 14:43:57
Product	Firefox
Version	13.0a1
Build ID	20120207031136
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	AuthenticAMD family 16 model 2 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address	0x683b4194
User Comments	loading story from msnbc.com 911 tapes article
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x9610, AdapterSubsysID: 2a7f103c, AdapterDriverVersion: 8.881.0.0
D2D? D2D+
DWrite? DWrite+
D3D10 Layers? D3D10 Layers+
EMCheckCompatibility	True

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	mozilla::plugins::PluginInstanceParent::~PluginInstanceParent 	dom/plugins/ipc/PluginInstanceParent.cpp:110
1 	xul.dll 	mozilla::plugins::PluginInstanceParent::`scalar deleting destructor' 	
2 	xul.dll 	nsCOMPtr_base::assign_from_qi 	obj-firefox/xpcom/build/nsCOMPtr.cpp:96
3 	xul.dll 	NS_GetInnermostURI 	obj-firefox/dist/include/nsNetUtil.h:1573
4 	xul.dll 	nsScriptSecurityManager::CheckLoadURIWithPrincipal 	caps/src/nsScriptSecurityManager.cpp:1429
5 	mozjs.dll 	js::detail::HashTable<js::Shape* const,js::HashSet<js::Shape*,js::ShapeHasher,js::SystemAllocPolicy>::SetOps,js::SystemAllocPolicy>::lookup 	obj-firefox/dist/include/js/HashTable.h:464
6 	mozjs.dll 	js::InitialShapeEntry::match 	js/src/jsscope.cpp:1417
7 	mozjs.dll 	js::detail::HashTable<js::InitialShapeEntry const,js::HashSet<js::InitialShapeEntry,js::InitialShapeEntry,js::SystemAllocPolicy>::SetOps,js::SystemAllocPolicy>::lookup 	obj-firefox/dist/include/js/HashTable.h:464
8 	mozglue.dll 	idalloc 	memory/jemalloc/jemalloc.c:4641
9 	mozglue.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6306
10 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.cpp:439
11 	xul.dll 	nsTHashtable<nsBaseHashtableET<nsCStringHashKey,nsFactoryEntry*> >::s_MatchEntry 	obj-firefox/dist/include/nsTHashtable.h:442
12 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.cpp:439
13 	xul.dll 	nsStyleContext::CalcStyleDifference 	layout/style/nsStyleContext.cpp:484
14 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.cpp:625
15 	xul.dll 	nsScriptSecurityManager::QueryInterface 	caps/src/nsScriptSecurityManager.cpp:513
16 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1410
17 	xul.dll 	nsRefPtr<nsIDOMEventListener>::~nsRefPtr<nsIDOMEventListener> 	obj-firefox/dist/include/nsAutoPtr.h:908
18 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1410
19 	xul.dll 	nsINode::AddEventListener 	content/base/src/nsGenericElement.cpp:1100
20 	xul.dll 	nsPluginHost::InstantiateEmbeddedPlugin 	dom/plugins/base/nsPluginHost.cpp:1033
21 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:522
22 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:549
23 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5454
24 	xul.dll 	nsJSContext::Release 	dom/base/nsJSEnvironment.cpp:1168
25 	xul.dll 	nsTHashtable<nsBaseHashtableET<nsCStringHashKey,nsFactoryEntry*> >::s_MatchEntry 	obj-firefox/dist/include/nsTHashtable.h:442
26 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.cpp:472
27 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.cpp:439
28 	xul.dll 	xul.dll@0x12c0ff 	
29 		@0x12e51caf 	
30 	xul.dll 	nsRefPtr<nsIDOMEventListener>::~nsRefPtr<nsIDOMEventListener> 	obj-firefox/dist/include/nsAutoPtr.h:908
31 	xul.dll 	nsComponentManagerImpl::GetService 	xpcom/components/nsComponentManager.cpp:1215
32 	xul.dll 	nsHTMLDocument::QueryInterface 	content/html/document/src/nsHTMLDocument.cpp:287
33 	xul.dll 	nsCOMPtr_base::assign_from_qi 	obj-firefox/xpcom/build/nsCOMPtr.cpp:96
34 	xul.dll 	nsObjectLoadingContent::InstantiatePluginInstance 	content/base/src/nsObjectLoadingContent.cpp:637

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Aplugins%3A%3APluginInstanceParent%3A%3A~PluginInstanceParent%28%29
Blocks: 90268
Keywords: regression
OS: Windows NT → Windows 7
Summary: crash mozilla::plugins::PluginInstanceParent:: → crash @ mozilla::plugins::PluginInstanceParent::~PluginInstanceParent with Flashblock
Version: Trunk → 13 Branch
I've not had anymore crashes with this sig since 
https://bugzilla.mozilla.org/show_bug.cgi?id=723473  landed.

Closing this as Fixed by bug 723473
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 723473
Resolution: --- → FIXED
The latest crash happened in 13.0a1/20120208. So the first patch of bug 723473 fixed it.
Status: RESOLVED → VERIFIED
No longer depends on: 723473
Resolution: FIXED → DUPLICATE
Duplicate of bug: 723473
You need to log in before you can comment on or make changes to this bug.