Last Comment Bug 725289 - Unprefix Blob.mozSlice
: Unprefix Blob.mozSlice
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Matthew Schranz [:mjschranz]
:
Mentors:
: 727576 (view as bug list)
Depends on: 732709 757284
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-08 06:03 PST by Simon Pieters
Modified: 2012-05-23 08:34 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch removing moz prefix (6.63 KB, patch)
2012-02-10 08:28 PST, Matthew Schranz [:mjschranz]
jonas: review+
Details | Diff | Review
Proposed patch removing moz prefix (33.23 KB, patch)
2012-02-10 17:09 PST, Matthew Schranz [:mjschranz]
schranz.m: review+
Details | Diff | Review
Proposed patch removing moz prefix (24.45 KB, patch)
2012-02-15 21:04 PST, Matthew Schranz [:mjschranz]
schranz.m: review+
Details | Diff | Review

Description Simon Pieters 2012-02-08 06:03:04 PST
User Agent: Opera/9.80 (Macintosh; Intel Mac OS X 10.7.2; U; en) Presto/2.10.229 Version/11.61

Steps to reproduce:

Please rename Blob.mozSlice to Blob.slice. Opera is working on changing the semantics of Blob.slice, but we don't want to prefix it. Since Gecko and WebKit have been shipping without Blob.slice support for several months, the existing content, if any, that relied on the old semantics of Blob.slice have had the chance to break and get updated. With Opera soon shipping Blob.slice with the new semantics, it's time to drop the prefix.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-02-08 06:09:29 PST
I think we should do this.
Comment 2 Jonas Sicking (:sicking) 2012-02-08 11:40:18 PST
I agree!
Comment 3 Matthew Schranz [:mjschranz] 2012-02-10 08:28:59 PST
Created attachment 596057 [details] [diff] [review]
Proposed patch removing moz prefix

I imagine I might need to fix some of the current tests for this too, but I wanted to make sure the changes in the code were correct first before doing so.
Comment 4 Jonas Sicking (:sicking) 2012-02-10 10:34:28 PST
Comment on attachment 596057 [details] [diff] [review]
Proposed patch removing moz prefix

Review of attachment 596057 [details] [diff] [review]:
-----------------------------------------------------------------

You need to update tests too. r=me once you do.

::: content/base/public/nsIDOMFile.idl
@@ +59,5 @@
>  interface nsIURI;
>  interface nsIPrincipal;
>  interface nsIDOMBlob;
>  
> +[scriptable, builtinclass, uuid(6640c2aa-fac0-497f-ba0f-60506f9a489f)]

This change doesn't affect the binary signature, so no need to rev the IID.
Comment 5 Matthew Schranz [:mjschranz] 2012-02-10 17:09:26 PST
Created attachment 596234 [details] [diff] [review]
Proposed patch removing moz prefix

Should cover it.
Comment 6 Matthew Schranz [:mjschranz] 2012-02-10 17:10:58 PST
You know, might have used the wrong command there when renaming the file. Let me know if that causes an issue.
Comment 7 Jonas Sicking (:sicking) 2012-02-10 20:00:32 PST
Yeah, we'd prefer to keep the history. If you use "hg mv oldname newname" that should produce a better diff.
Comment 8 Jonas Sicking (:sicking) 2012-02-10 20:00:51 PST
And it'll make reviewing easier :)
Comment 9 Matthew Schranz [:mjschranz] 2012-02-15 21:04:45 PST
Created attachment 597682 [details] [diff] [review]
Proposed patch removing moz prefix

Simply forgot a flag I need when generating patches with git!
Comment 10 Masatoshi Kimura [:emk] 2012-02-15 22:37:31 PST
*** Bug 727576 has been marked as a duplicate of this bug. ***
Comment 13 Ed Morley [:emorley] 2012-02-17 05:36:11 PST
https://hg.mozilla.org/mozilla-central/rev/23a142cb2fc1
Comment 14 Ed Morley [:emorley] 2012-02-17 05:42:49 PST
and https://hg.mozilla.org/mozilla-central/rev/1f99e7a087c1
Comment 15 Daniel Desira 2012-02-19 14:28:02 PST
Do you need verification that the bug is fixed? I am more than willing to do it.
Comment 16 Eric Shepherd [:sheppy] 2012-04-29 10:47:28 PDT
Docs updated:

https://developer.mozilla.org/en/DOM/Blob

Added to Firefox 13 for developers.

Note You need to log in before you can comment on or make changes to this bug.