User Agent: Opera/9.80 (Macintosh; Intel Mac OS X 10.7.2; U; en) Presto/2.10.229 Version/11.61 Steps to reproduce: Please rename Blob.mozSlice to Blob.slice. Opera is working on changing the semantics of Blob.slice, but we don't want to prefix it. Since Gecko and WebKit have been shipping without Blob.slice support for several months, the existing content, if any, that relied on the old semantics of Blob.slice have had the chance to break and get updated. With Opera soon shipping Blob.slice with the new semantics, it's time to drop the prefix.
I think we should do this.
Created attachment 596057 [details] [diff] [review] Proposed patch removing moz prefix I imagine I might need to fix some of the current tests for this too, but I wanted to make sure the changes in the code were correct first before doing so.
Comment on attachment 596057 [details] [diff] [review] Proposed patch removing moz prefix Review of attachment 596057 [details] [diff] [review]: ----------------------------------------------------------------- You need to update tests too. r=me once you do. ::: content/base/public/nsIDOMFile.idl @@ +59,5 @@ > interface nsIURI; > interface nsIPrincipal; > interface nsIDOMBlob; > > +[scriptable, builtinclass, uuid(6640c2aa-fac0-497f-ba0f-60506f9a489f)] This change doesn't affect the binary signature, so no need to rev the IID.
Created attachment 596234 [details] [diff] [review] Proposed patch removing moz prefix Should cover it.
You know, might have used the wrong command there when renaming the file. Let me know if that causes an issue.
Yeah, we'd prefer to keep the history. If you use "hg mv oldname newname" that should produce a better diff.
And it'll make reviewing easier :)
Created attachment 597682 [details] [diff] [review] Proposed patch removing moz prefix Simply forgot a flag I need when generating patches with git!
Do you need verification that the bug is fixed? I am more than willing to do it.
Docs updated: https://developer.mozilla.org/en/DOM/Blob Added to Firefox 13 for developers.