"Reason given" is not contained in the email for new request refund for an app

VERIFIED FIXED in 6.4.1

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Cristian Boldan, Assigned: cvan)

Tracking

unspecified
6.4.1

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 595404 [details]
reason given

Steps to reproduce:
1. Login to APPS https://apps-preview-dev.allizom.org/en-US/apps/
2. Click on "My Purchases" link.
3. Click on "Request support" from an paid app that was purchased.
4. Click on "I want to request a refund" link and Continue button.
5. Enter a reason in the text field and click Request Refund.
6. Verify the email for the Requested Refund app on which email account was enrolled in marketplace.

Expected results:
The email contains: user email, purchase date, price, reason given and link to approve or deny the request.

Actual results:
The email contains "Your add-on, {appid}, has received a new refund request:", and the reason given detail is missing.

Notes/Issues:
Attaching screenshot for this issue
(Reporter)

Updated

6 years ago
Blocks: 718560
(Assignee)

Updated

6 years ago
Assignee: nobody → cvan
OS: Windows 7 → All
Hardware: x86_64 → All
Target Milestone: --- → 6.4.1
(Assignee)

Comment 1

6 years ago
https://github.com/mozilla/zamboni/commit/57d5ad3
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 2

6 years ago
this looks fixed.
Status: RESOLVED → VERIFIED

Comment 3

6 years ago
Created attachment 595856 [details]
post-fix screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.