Closed Bug 725309 Opened 8 years ago Closed 8 years ago

mozconfig comparison gets confused by identical lines in different places

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 725303

People

(Reporter: bhearsum, Assigned: aki)

References

Details

(Whiteboard: [automation][releases])

The mozconfig comparison for 10.0.1 complained about MOZ_MAKE_FLAGS, like this:
2012-02-08 05:30:44,783 : ERROR : not in release mozconfig's whitelist (releases/mozilla-release/macosx64/nightly) : mk_add_options MOZ_MAKE_FLAGS="-j4"

However, manual inspection of the files shows that both mozconfigs have that line:
 % pwd
/home/bhearsum/Mozilla/checkouts/clean/mozilla-release/browser/config/mozconfigs/macosx-universal
bhearsum@voot ~/Mozilla/checkouts/clean/mozilla-release/browser/config/mozconfigs/macosx-universal
 % cat nightly
. $topsrcdir/build/macosx/universal/mozconfig

# Universal builds override the default of browser (bug 575283 comment 29)
ac_add_options --enable-application=browser

ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}
ac_add_options --enable-update-packaging
ac_add_options --enable-codesighs
ac_add_options --disable-install-strip

# Needed to enable breakpad in application.ini
export MOZILLA_OFFICIAL=1

export MOZ_TELEMETRY_REPORTING=1
mk_add_options MOZ_MAKE_FLAGS="-j4"

ac_add_options --with-macbundlename-prefix=Firefox
bhearsum@voot ~/Mozilla/checkouts/clean/mozilla-release/browser/config/mozconfigs/macosx-universal
 % cat release
. $topsrcdir/build/macosx/universal/mozconfig

# Universal builds override the default of browser (bug 575283 comment 29)
ac_add_options --enable-application=browser

ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}
ac_add_options --enable-update-packaging
ac_add_options --enable-official-branding

# Needed to enable breakpad in application.ini
export MOZILLA_OFFICIAL=1

export MOZ_TELEMETRY_REPORTING=1

# Enable parallel compiling
mk_add_options MOZ_MAKE_FLAGS="-j4"

I think something about the placement of the line in each mozconfig messes it up. We should fix the comparison logic.
Assignee: nobody → lsblakk
Assignee: lsblakk → aki
Fixing in bug 725303.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 725303
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.