Scrolling and Some Rendering Unresponsive After Mac Wakeup

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Randy Baird, Unassigned)

Tracking

10 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

1) Macbook Pro 8,2 running OS X 10.6.8 in clamshell mode, external monitor running at 1680x1050.

2) Firefox can run on any page and problem will occur.  Problem reproduces in safe mode.

3) Force Mac to sleep with Firefox active.

4) Wake Mac up (I just scribble on a USB wireless mouse to force wakeup).


Actual results:

Following wakeup, the following behavior persists for greater than one minute:

1) Page rendering area won't scroll using scroll wheel on mouse, arrow keys, or on-screen line-by-line scrolling controls.  However, dragging the elevator does successfully scroll the page.

2) Clicking through links on the page or selecting a bookmark does cause a new page to be successfully rendered.  However, the new page has the same scrolling problems.

3) Moving to the gmail page won't render in full mode but **will** render in HTML mode.

4) Typing in text boxes works OK, arrow keys work to scroll OK, elevator in a scrolling text box is OK, but line-by-line scroll control or mouse scroll wheel doesn't work.

5) Problem goes away after a few minutes with no ill effects.

6) Problem was first noticed in the 9 branch.  10 branch didn't fix it.  Problem appears to be 100% reproducible.
(Reporter)

Comment 1

6 years ago
Problem still occurs in 10.0.1.

Also found two additional unresponsive features that clear up with everything else after a few minutes:

1) Can't switch between tabs.

2) URL completion in the address bar doesn't work.

Comment 2

6 years ago
Can you see if the issue is still reproducing on the latest Nightly.
You can downloaded it from here: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
(Reporter)

Comment 3

6 years ago
Vlad, the nightly actually seems a bit worse.  In the nightly, dragging the elevator no longer causes a scroll or, in some cases, it scrolls for a small distance and then becomes unresponsive.
Randy, can you please test this with older versions of Firefox to see where the issue first starts for you?

ftp://ftp.mozilla.org/pub/firefox/releases/

Vlad, are you able to reproduce this issue?
(Reporter)

Comment 5

6 years ago
OK, all sorts of strangeness.  First, rolling all the way back to 7.0.1, I still had the problem, and I know that it was working back then.  So it's something to do with OS X.

I went back into the update log and discovered the OS X updates at just about the time the bug manifested itself.  I did the OS X update on 1/19/12, and, since 9.0 came out in late December, it's entirely possible that I did both the Mac upgrade and the Firefox upgrade simultaneously.  The relevant modules that updated in OS X:

MacBook Pro SMC Firmware Update 1.5
MacBook Pro EFI Firmware Update 2.3
Java for Mac OS X 10.6 Update 6 6.0

Then, just for grins and giggles, I did an update search and installed the following just now:

MacBook Pro EFI Firmware Update 2.3 (no clue why it installed the same version twice)
Security Update 2012-001 1.1

***The problem went away following the update.***

Don't know whether you guys want to look at this any more or not.  It still could be a real bug (my bet was on the Java update for about 5 minutes there), but I can no longer reproduce it.

Thanks for your help.
Resolving WORKSFORME based on the last comment. Randy, thanks for the thoroughness on this bug. Please reopen if the issue starts happening again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.