Closed Bug 725389 Opened 9 years ago Closed 9 years ago

Top sites section is squished

Categories

(Firefox for Android Graveyard :: General, defect, P2)

ARM
Android
defect

Tracking

(firefox14 verified, firefox15 verified, blocking-fennec1.0 +)

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- verified
firefox15 --- verified
blocking-fennec1.0 --- +

People

(Reporter: blassey, Assigned: lucasr)

References

Details

Attachments

(2 files)

Attached image screenshot
see screenshot
Priority: -- → P2
Summary: Top sites section is squished on Nexus One running Eclair → Top sites section is squished on Nexus One
blocking-fennec1.0: --- → +
Status: NEW → ASSIGNED
Summary: Top sites section is squished on Nexus One → Top sites section is squished on Nexus One running Eclair
I've seen this on other phones and more recent Android versions than Eclair. Though it has been weeks since I've seen this.
Summary: Top sites section is squished on Nexus One running Eclair → Top sites section is squished
I need a reliable way to reproduce this bug in order to fix it. I've never seen this happen myself. Brad, does it consistently happen in Eclair?
I don't see this anymore
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Saw this on Damon's phone today.
Status: REOPENED → NEW
Looking for STR for this bug.
Keywords: qawanted
What's his phone/os?
OS: Mac OS X → Android
Hardware: x86 → ARM
I don't believe this to be phone specific. But ftr he has a Galaxy Nexus. This has something to do with switching back and forth between Firefox having focus with about:home showing. Try using the home button, back button, switching button or other methods to switch focus.
I cannot reproduce this.   HTC Sensation, 2.3.4, Samsung Galaxy Nexus 4.0.2. , 04-18-2012 build.  

If someone else gets it, please comment.  leaving qawanted keyword in here for others.
I cannot reproduce this either on Samsung Galaxy S (2.2). I followed Kevin's suggestions but excepting bug 746548 (which might occur sometimes) everything works fine.
I cannot reproduce on Samsung Galaxy SII 2.3.4 using the latest nightly (2012-04-18).
I cannot reproduce on Galaxy Nexus (ICS) and Nexus S (Gingerbread).
Same here, unable to reproduce on a Nexus One (2.3), Xperia Play (2.3) ...
Keywords: qawanted
str:
1. view about:home in landscape
2. press home button to return to hone screen
3. rotate device to portrait
4. open fennec, which should show up in portrait
Thanks microrffr.

Unfortunately, I could not repro on LG Revolution/HTC Desire HD with STRs from Comment 14 and today's nightly 4/24.  I think this might be device specific.
I can see it here on a GN.
And now I can't on Aurora with Galaxy Nexus.  Maybe there is some additional step in the STR i did unknowingly?
Looks like a very rare race when switching device orientation while not in the app. I wouldn't say this is a release blocker. I'm having a look at this right now anyway.
Can we add some logging that might be useful in those cases when someone can reproduce it? Maybe someone could attach to ADB and get a clue.
I tried very hard to do the right thing (tm) and use auto_fit with columnWidth stretch mode in our Top Sites' grid view but it just doesn't do what you'd expect when in landscape orientation. After reading GridView's source code a bit, it looks like there's actually a bug there.

So, I decided to just move the updates to the number of columns to our overridden onMeasure() method, which will ensure there's no layout race when changing device orientation. This is a bit of hacky approach because setting number of columns should cause a relayout on the view. Doing that inside onMeasure is... non-ideal but works fine. It seems Android can cope well with recursive relayout requests from views.

I couldn't reproduce this bug anymore with this patch (following STR described in comment 14)
Duplicate of this bug: 748442
Attachment #621083 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/6c7db62eb29c
Status: NEW → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Comment on attachment 621083 [details] [diff] [review]
Set number of columns in top site's grid view onMeasure

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: about:home (a hightly visible part of our UI might look pretty bad in certain cases)
Risk to taking this patch (and alternatives if risky): not risky, simple change
String changes made by this patch: n/a

Mobile-only, release blocker.
Attachment #621083 - Flags: approval-mozilla-aurora?
We are leaving all non-beta+ bugs nominated for Aurora approval in the queue until FN14 Beta 1 is signed off on by QA.
Attachment #621083 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified/Fixed on:
Nightly Fennec 15.0a1 (2012-05-29)
Aurora Fennec 14.0a2 (2012-05-29)
Devices: HTC Desire Z (Android 2.3.3), Samsung Captivate (Android 2.2)

Verified using the STR from comment 14.
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.