Potential Problem with Jetpack Add-on SDK and OpenSUSE 12.1

UNCONFIRMED
Unassigned

Status

Mozilla Labs
Jetpack SDK
--
critical
UNCONFIRMED
6 years ago
6 years ago

People

(Reporter: Dennis Baldwin, Unassigned)

Tracking

({crash})

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

When a user installed our add-on in Firefox 9.0.1 it immediately crashed her browser on next start. She's running OpenSUSE 12.1. This resulted in the crash report attached to this bug. After much back and forth we've narrowed the crash down to any add-on that is built with the Jetpack add-on SDK. Our add-on is PriceBlink and other Jetpack add-ons that cause her browser to crash are:

Fastest Search 1.98
Awesome Screenshot 2.3.6


Actual results:

Tried to open Firefox and browser immediately crashed.


Expected results:

Firefox should have opened without error.
(Reporter)

Updated

6 years ago
OS: Mac OS X → Linux
Hardware: x86 → x86_64
Your forgot to attach the crash report.
(Reporter)

Comment 2

6 years ago
My apologies. I clicked on "Report this Crash" from the crash report page and assumed it would automatically link it. Here it is:

https://crash-stats.mozilla.com/report/index/bp-b9970ade-c25b-4edf-8e0f-7508a2120116
Is the crash report from an Suse build of Firefox ?
The crash report is without symbols and useless :-(

Could you use a Mozilla.org binary build, run it from /tmp and submit a new crash report from this build ?
Duplicate of this bug: 726113
(Reporter)

Comment 5

6 years ago
Matthias, I just wanted to circle back on this issue. Kevin pointed out that I created a new bug when I should have just updated this ticket. Here is the most recent Crash Report which hopefully has what you need.

https://crash-stats.mozilla.com/report/index/bp-2ef3cc77-71a8-4f69-bf71-55c932120210

Thanks!
Is this from a Mozilla.org binary build or from an Opensuse build ?
The symbols are missing in the stack from your crash report.
I may have to ask the soccoro Team why the Linux symbols are missing but that makes only sense for a Mozilla.org build. I doubt that OpenSuse uploads the symbols to the soccoro server.
(an example for a crash ID with symbols: bp-2de3a5b1-afc7-4a04-a2fa-357f22120215 )
(Reporter)

Comment 7

6 years ago
I believe it is from a binary build downloaded from here:

ftp://ftp.mozilla.org/pub/firefox/releases/9.0.1/linux-x86_64/en-US/

I've been working directly with our add-on user to try and get you the necessary information since I don't have access to an OpenSUSE environment. Actually, I take that back...I tried this on OpenSUSE once (via Parallels) and did not experience the crash. She's consistently seeing this crash with our add-on or any add-on that uses the Jetpack SDK.

Here are the steps she sent to create the crash report:

"I copied the zip file to /tmp, extracted it, ran it from /tmp and it ran Firefox with my profile, like it didn't know it was any different. (I was expecting a blank profile, not the one I use everyday.) So I created a blank profile, like I did for you before, let your add-on crash it, and submitted a report."
moving to Jetpack. This looks like a core crash but they may have a clue whats wrong here.

Kairo: Do you know why the symbols for the official builds aren't working on linux ?
Severity: normal → critical
Component: Untriaged → Jetpack SDK
Keywords: crash
Product: Firefox → Mozilla Labs
QA Contact: untriaged → jetpack-sdk
Version: 9 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.