Firefox doesn't support some new html5 input types

RESOLVED DUPLICATE of bug 344614

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 344614
7 years ago
7 years ago

People

(Reporter: Ma Hsiao-Chun, Unassigned)

Tracking

10 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

I tried code examples in the following page
http://www.w3schools.com/html5/att_input_type.asp
They are about <input type="XXX" />




Actual results:

Some of the newly added types are not supported, they fall back to "text" type.
The page also documents the current supporting state of Firefox and other browsers. I verified the state of Firefox using Firefox 10.0


Expected results:

I guess we'd reference HTML5 specification
http://www.w3.org/TR/html5/states-of-the-type-attribute.html#states-of-the-type-attribute

Or we can just reference another browser, say, Google Chrome or Opera.

Comment 1

7 years ago
And as a side note, don't use w3schools.com as reference, that site is problematic in many ways http://w3fools.com/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 344614
You need to log in before you can comment on or make changes to this bug.