Command line option "createprofile" doesn't work on HP-UX systems with NFS2

RESOLVED WORKSFORME

Status

P4
normal
RESOLVED WORKSFORME
18 years ago
2 years ago

People

(Reporter: jimmyu, Assigned: shannond)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When using the option "createprofile" it says that the user profile is created
but nothing is there in the .mozilla directory. And using "selectprofile" option
you do not see the previous created user profile available.
But the other instance of "createprofile" works, eg. ./netscape -createdprofile
"jimmy /u/jimmyu/temp" which is to create user profile 'jimmy' in the temp
subdirectory.

Steps to reproduce:
1) login to "pesaro"
2) cd /opt/netscape6
3) type ./netscape -createprofile test
4) enter

Result: User profile "test" is created but actually not and return back to
command prompt. Also sometimes the result will bring up the Profile Manager
window. Which can be launch by using ./netscape -profilemanager

Actual result: User profile created and return back to command prompt.
(Reporter)

Updated

18 years ago
Blocks: 18687
QA Contact: gbush → jimmyu

Comment 1

18 years ago
looks like it might be a multiple processor issue, I'm checking on 11.00 on
siena to test if we see this on a 11.00 multiple processors machine
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

18 years ago
works on salerno - 2 processor machine running 11.00
doesn't work on esopus - 2 processor machine running 11i
doesn't work on pesaro - 2( or 4 ) processor machine running 11i
works on assisi - 1 processor machine running 11i

Comment 3

18 years ago
*** Bug 75597 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Using the HP 6.01 RTM candidite (ximian build) this now also fails on assisi 
(single processor).
(Reporter)

Comment 5

18 years ago
Ok, more info in regard to this problem:
1) we can now duplicate this on "assisi" (single processor) with either Ximian
or Beta build.
2) this problem only happens if your home direcotry is NFS mount, i.e. local
users will not have this problem.

"assisi" was having other problem with N4.75 hence the OS was re-install, thus
stablized the OS on par with the other 11i machines. Hopefully, this is the
problem that we are seeing weird stuffs happening on single or multi processor
11i machines.

Comment 6

18 years ago
This has  a work-around of using the -profilemanager command line option. Not
sure if this bug is branch only.
Assignee: jgaunt → shannond
Status: ASSIGNED → NEW
(Reporter)

Comment 7

18 years ago
This problem is the same running the HP trunk build ID 2001041909.

ONLY HAPPENS ON 11i MACHINES W/ NFS HOME DIRECTORY, WORKS FINE WITH LOCAL HOME
USERS!



(Assignee)

Comment 8

18 years ago
This is not an 11i only issue. If I rlogin to pesaro from sorrento, my HOME
environment setting is /u/shannond, however if I 'pwd' from my home dir it says
/tmpmnt/u/shannond.  If I reset my HOME environment variable to
/tmpmnt/u/shannond, the createprofile is successful on pesaro.  I see the same
problem and resolution on bologna.  Aki says that this is the difference between
nfs2 and nfs3.  nfs2 having /tmpmnt/u and nfs3 having /u.  It was coincidental
at the time that this bug appeared that the 11i machines were all nfs2 and the
11.0 machines were mostly nfs3 but we have since moved our 11.0 machines to
nfs2.  It looks like the problem occurs when logging into a machine with nfs2
from a machine with nfs3.  I'll test the other way to see if its a problem from
nfs2 to nfs3.  
Status: NEW → ASSIGNED
(Assignee)

Comment 9

18 years ago
the /u directory is linked to the /tmp_mnt/u directory on systems with nfs2.
For some reason when using the -createprofile option mozilla seems to not be
able to follow the link to create the directory where using the -profilemanager
workaround mentioned by John can.
(Assignee)

Comment 10

18 years ago
correction:  the /u/<user> is linked to /tmp_mnt/u/<user>
(Assignee)

Comment 11

18 years ago
Changing summary to reflect problem
Summary: Command line option "createprofile" doesn't work on HP-UX 11i Server machine → Command line option "createprofile" doesn't work on HP-UX systems with NFS2

Comment 12

18 years ago
Tried this on a J7000 (4-cpu) system at HP-FTC, RTM version of N6.01 for HP-UX
11i.

Nothing crashs, but the profile creates a profile tree in 
$HOME/.mozilla/test/test/rifyci5y.slt/ 

whereas my 'normal' profile is in
$HOME/.mozilla/lamia/px1ufvqy.slt/

Odd, but it seems to work OK on re-entry to N6.

Comment 13

18 years ago
It's still failing here.  Out of curiosity, what shell are you using?  It may be
possible this is a shell related problem.

Comment 14

17 years ago
adding (hp11i) to summary.  Not sure how this one was missed.....
Summary: Command line option "createprofile" doesn't work on HP-UX systems with NFS2 → (hp11i) Command line option "createprofile" doesn't work on HP-UX systems with NFS2
(Assignee)

Comment 15

17 years ago
This isn't an 11i problem like we thought before ... its an nfs 2 problem.  You
can reproduce this on any 11.0 machine now too.  11.0 machines were previously
nfs 3 (where this is not a bug) but when we switched to nfs 2 this bug showed up
on both 11.0 and 11i.  See my comment from 5-17.
Summary: (hp11i) Command line option "createprofile" doesn't work on HP-UX systems with NFS2 → Command line option "createprofile" doesn't work on HP-UX systems with NFS2
(Assignee)

Comment 16

17 years ago
Setting priority for the radar. (for Rob who does not have permission to do so)
Priority: -- → P4
(Reporter)

Comment 17

17 years ago
This apparently is now working fine with the HPUX N6.2 build 20011101 on NFS 2
systems.

Marking WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.