Firefox keeps crashing when using IBM Lotus Notes iWeb

RESOLVED DUPLICATE of bug 722039

Status

()

--
critical
RESOLVED DUPLICATE of bug 722039
7 years ago
7 years ago

People

(Reporter: shaun_storey, Unassigned)

Tracking

({crash})

10 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129141257

Steps to reproduce:

Try and send a email using IBM Lotus Notes iWeb.


Actual results:

Firefox crashes.


Expected results:

Email should be sent

Comment 1

7 years ago
Please provide a crash id -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

7 years ago
I've added two crash id's in the Crash Signatures box. The make mention as much as I can read them about pixmaps and NVIDIA (which is the graphic card and driver I use in ubuntu 11.10.

I will try it with Safe Mode and get back to you.

It was with a clean profile as I moved to a freshly installed machine that day.
Crash Signature: bp-25132215-3390-42d4-a073-c52ac2120208 bp-99ac167e-1080-45bb-9da3-ea4ae2120208
(Reporter)

Comment 3

7 years ago
Tried with Safe Mode and it crashed also.
Crash Signature: bp-25132215-3390-42d4-a073-c52ac2120208 bp-99ac167e-1080-45bb-9da3-ea4ae2120208 → bp-25132215-3390-42d4-a073-c52ac2120208 bp-99ac167e-1080-45bb-9da3-ea4ae2120208 Safe Mode Crash bp-00c9526c-8828-4388-a304-ffef92120210

Comment 4

7 years ago
Please post the contents of about:support as a text attachment to this bug
Crash Signature: bp-25132215-3390-42d4-a073-c52ac2120208 bp-99ac167e-1080-45bb-9da3-ea4ae2120208 Safe Mode Crash bp-00c9526c-8828-4388-a304-ffef92120210 → [@ nsTArray<RangeData, nsTArrayDefaultAllocator>::DestructRange | nsTArray<RangeData, nsTArrayDefaultAllocator>::RemoveElementsAt | nsTypedSelection::AddItem ] [@ nsCOMPtr_base::~nsCOMPtr_base | nsTArray<RangeData nsTArrayDefaultAllocator>::RemoveElemen…
(Reporter)

Comment 5

7 years ago
Attached the contents of about:support     ... FYI my ubuntu installation got firefox update 10.0.1 today so will let you know whats happens

  Application Basics

        Name
        Firefox

        Version
        10.0.1

        User Agent
        Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Firebug
        1.9.1
        true
        firebug@software.joehewitt.com

        Global Menu Bar integration
        2.0.2
        true
        globalmenu@ubuntu.com

        Ubuntu Firefox Modifications
        1.0.2
        true
        ubufox@ubuntu.com

        Web Developer
        1.1.9
        true
        {c45c406e-ab73-11d8-be73-000a95be3b12}

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20120210025125

        browser.startup.homepage_override.mstone
        rv:10.0.1

        browser.tabs.warnOnClose
        false

        extensions.lastAppVersion
        10.0.1

        gfx.blacklist.suggested-driver-version
        NVIDIA 257.21

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1328539028

        places.history.expiration.transient_current_max_pages
        104858

        places.history.expiration.transient_optimal_database_size
        167772160

        plugin.soname.list
        libXt.so:libXext.so

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        NVIDIA Corporation -- Quadro NVS 420/PCI/SSE2

        Driver Version
        3.3.0 NVIDIA 290.10

        WebGL Renderer
        NVIDIA Corporation -- Quadro NVS 420/PCI/SSE2 -- 3.3.0 NVIDIA 290.10

        GPU Accelerated Windows
        0/1
(Reporter)

Comment 6

7 years ago
Sorry just realised the about:support about was down after the update was automcatically applied......
(Reporter)

Comment 7

7 years ago
Also crashes in firefox 10.0.1 submitted report bp-7ab8e9f9-f39d-49c9-b2ee-cc9922120214
(Reporter)

Updated

7 years ago
Summary: Firefox keeps crahsing → Firefox keeps crashing
Mozilla/5.0 (X11; Linux x86_64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1

Shaun, could you provide a link to the exact version of the mail you are using? I guess you don't have a test account there somewhere, do you?
(Reporter)

Comment 9

7 years ago
The version in the about is quoted as

 IBM Lotus iNotes 8.5.2, Build 401.15,June 20, 2011

Unfortunately it is work email so not externally accessible.

My team all got new developement machines and have the same software build as I have and they also report FF regularly crashes doing the same thing. The issue happens when you click the send button only it appears. Some emails work but I would say it crashes once every 2 or 3 emails. It is consistent in that if the email sends it will always send but if it fails it will always fail. To this end I have tried all sorts of options to understand thing, new vs replied mails, body with brackets, apostrophes & other characters but I can't find a pattern.
Without a testcase or access to the application this would be hard to reproduce.
Crash Signature: [@ nsTArray<RangeData, nsTArrayDefaultAllocator>::DestructRange | nsTArray<RangeData, nsTArrayDefaultAllocator>::RemoveElementsAt | nsTypedSelection::AddItem ] [@ nsCOMPtr_base::~nsCOMPtr_base | nsTArray<RangeData nsTArrayDefaultAllocator>::RemoveElemen… → [@ nsTArray<RangeData, nsTArrayDefaultAllocator>::DestructRange | nsTArray<RangeData, nsTArrayDefaultAllocator>::RemoveElementsAt | nsTypedSelection::AddItem ] [@ nsCOMPtr_base::~nsCOMPtr_base | nsTArray<RangeData nsTArrayDefaultAllocator>::RemoveElemen…
Summary: Firefox keeps crashing → Firefox keeps crashing when using IBM Lotus Notes iWeb
I'm pretty sure this is the same crash as in bug 722039, so let's continue
the triage there...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 722039
You need to log in before you can comment on or make changes to this bug.