The default bug view has changed. See this FAQ.

[SeaMonkey] mochitest-a11y: test_embeds.xul needs to support non-Firefox applications too

VERIFIED FIXED in Firefox 12

Status

()

Core
Disability Access APIs
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: capella)

Tracking

(Blocks: 3 bugs)

Trunk
mozilla13
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox12 verified)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Newly added test, which needs similar fix as bug 717753 had in the meantime :-|

PS: Noticed in bug 717963 comment 1.

Updated

5 years ago
Blocks: 417472
(Assignee)

Comment 1

5 years ago
Created attachment 596278 [details] [diff] [review]
(Av1-moz12) test_embeds.xul: Use "browser.chromeURL" [Checkin: Comment 13]


   Okay, 1 file changed for this bug: test_embeds.xul.

   (Note self... review changeset 1a94821b465 associated with bug / file history, not simply bug attachments.)
Attachment #596278 - Flags: review?(sgautherie.bz)
(Reporter)

Comment 2

5 years ago
Comment on attachment 596278 [details] [diff] [review]
(Av1-moz12) test_embeds.xul: Use "browser.chromeURL" [Checkin: Comment 13]

This is a copy of what I did in bug 717753.
But you should use openBrowserWindow() from bug 719754 rewrite now.
Attachment #596278 - Flags: review?(sgautherie.bz) → review-
(Assignee)

Comment 3

5 years ago
Created attachment 596417 [details] [diff] [review]
(Bv1) test_embeds.xul: Use new openBrowserWindow()


   Now using common.js functions... openBrowserWindow(), etc.
Attachment #596278 - Attachment is obsolete: true
Attachment #596417 - Flags: review?(sgautherie.bz)
(Reporter)

Comment 4

5 years ago
Comment on attachment 596417 [details] [diff] [review]
(Bv1) test_embeds.xul: Use new openBrowserWindow()

Review of attachment 596417 [details] [diff] [review]:
-----------------------------------------------------------------

This looks very nice, well done! Just a few nits.

::: accessible/tests/mochitest/relations/test_embeds.xul
@@ +27,5 @@
>    <script type="application/javascript">
>    <![CDATA[
>      ////////////////////////////////////////////////////////////////////////////
>      // Helpers
>  

Nit: These 3 lines can go away too.

@@ +101,5 @@
>        gQueue.invoke();
>      }
>  
>      SimpleTest.waitForExplicitFinish();
> +    openBrowserWindow(doTests);

You missed to re-add |, "about:"| here.

@@ +116,5 @@
> +    <a target="_blank"
> +       href="https://bugzilla.mozilla.org/show_bug.cgi?id=725647"
> +       title="[SeaMonkey] mochitest-a11y: test_embeds.xul needs to support non-Firefox applications too">
> +      Mozilla Bug 725647
> +    </a>

Nit: I don't think adding this block is very valuable...
Attachment #596417 - Flags: review?(sgautherie.bz) → feedback+
(Reporter)

Updated

5 years ago
Depends on: 719754
(Assignee)

Comment 5

5 years ago
Created attachment 596560 [details] [diff] [review]
(Bv1a) test_embeds.xul: Use new openBrowserWindow()
[Checked in: Comment 9]


   Still swinging ... Nits fixed, agrees they look better.

   Apologies for missing the "about:" in the openBrowserWindow function ... I noticed it, but it looked optional... (I thought maybe loadURI or loadOneTab addressed it internally since RUNTESTS.py seemed ok, and I didn't look deeper into it ...)
Attachment #596417 - Attachment is obsolete: true
Attachment #596560 - Flags: review?(sgautherie.bz)
(Reporter)

Updated

5 years ago
Attachment #596560 - Attachment is patch: true
(Reporter)

Comment 6

5 years ago
Comment on attachment 596560 [details] [diff] [review]
(Bv1a) test_embeds.xul: Use new openBrowserWindow()
[Checked in: Comment 9]

(In reply to Mark Capella [:capella] from comment #5)
>    Apologies for missing the "about:" in the openBrowserWindow function ...
> I noticed it, but it looked optional...

Yeah, I don't know, so it's safer to keep it.
Reviewer should tell you if it can be removed.
Attachment #596560 - Flags: review?(sgautherie.bz) → review?(surkov.alexander)

Comment 7

5 years ago
Comment on attachment 596560 [details] [diff] [review]
(Bv1a) test_embeds.xul: Use new openBrowserWindow()
[Checked in: Comment 9]

r=me
Attachment #596560 - Flags: review?(surkov.alexander) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Reporter)

Comment 8

5 years ago
Comment on attachment 596278 [details] [diff] [review]
(Av1-moz12) test_embeds.xul: Use "browser.chromeURL" [Checkin: Comment 13]

Oh, actually I would like this patch to fix mozilla12 (too).
Attachment #596278 - Attachment description: bug725647.diff → (Av1-moz12) test_embeds.xul: Use "browser.chromeURL"
Attachment #596278 - Attachment is obsolete: false
Attachment #596278 - Flags: review?(surkov.alexander)
Attachment #596278 - Flags: review-
Attachment #596278 - Flags: feedback+
(Reporter)

Updated

5 years ago
Attachment #596417 - Attachment description: bug725647.diff2 → (Bv1) test_embeds.xul: Use new openBrowserWindow()
(Reporter)

Updated

5 years ago
Attachment #596560 - Attachment description: bug725647.diff3 → (Bv1a) test_embeds.xul: Use new openBrowserWindow()
(Reporter)

Comment 9

5 years ago
Comment on attachment 596560 [details] [diff] [review]
(Bv1a) test_embeds.xul: Use new openBrowserWindow()
[Checked in: Comment 9]

https://hg.mozilla.org/mozilla-central/rev/817614044d46
Attachment #596560 - Attachment description: (Bv1a) test_embeds.xul: Use new openBrowserWindow() → (Bv1a) test_embeds.xul: Use new openBrowserWindow() [Checked in: Comment 9]
(Reporter)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

5 years ago
Attachment #596278 - Flags: review?(surkov.alexander) → review+
(Reporter)

Comment 10

5 years ago
Comment on attachment 596278 [details] [diff] [review]
(Av1-moz12) test_embeds.xul: Use "browser.chromeURL" [Checkin: Comment 13]

[Approval Request Comment]
Regression caused by (bug #): Bug 707654.
User impact if declined: None, but perma-orange on SeaMonkey.
Testing completed (on m-c, etc.): Comment 9.
Risk to taking this patch (and alternatives if risky): None, test-only.
String changes made by this patch: None.
Attachment #596278 - Flags: approval-mozilla-aurora?
Comment on attachment 596278 [details] [diff] [review]
(Av1-moz12) test_embeds.xul: Use "browser.chromeURL" [Checkin: Comment 13]

[Triage Comment]
Test only fix - approved for Aurora 12.
Attachment #596278 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [c-n: Av1-moz12 to m-a]
(Reporter)

Comment 12

5 years ago
Mark, from now on, please include author and description to your patches:
see http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed

I did it for you for patch Bv1a.
Jens, please, do it for patch Av1-moz12 for this one time.
Comment on attachment 596278 [details] [diff] [review]
(Av1-moz12) test_embeds.xul: Use "browser.chromeURL" [Checkin: Comment 13]

http://hg.mozilla.org/releases/mozilla-aurora/rev/a08366de6833
Attachment #596278 - Attachment description: (Av1-moz12) test_embeds.xul: Use "browser.chromeURL" → (Av1-moz12) test_embeds.xul: Use "browser.chromeURL" [Checkin: Comment 13]
status-firefox12: affected → fixed
Keywords: checkin-needed
Whiteboard: [c-n: Av1-moz12 to m-a]
(Reporter)

Comment 14

5 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #9)
> https://hg.mozilla.org/mozilla-central/rev/817614044d46

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1329726992.1329731718.29744.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2012/02/20 00:36:32

V.Fixed


(In reply to Jens Hatlak (:InvisibleSmiley) from comment #13)
> http://hg.mozilla.org/releases/mozilla-aurora/rev/a08366de6833

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1330206173.1330211402.24221.gz
WINNT 5.2 comm-aurora debug test mochitest-other on 2012/02/25 13:42:53

firefox12: verified.
Status: RESOLVED → VERIFIED
status-firefox12: fixed → verified
No longer depends on: 712540
You need to log in before you can comment on or make changes to this bug.