Position absolute in display: box doesn't respect relative parent

RESOLVED DUPLICATE of bug 34294

Status

()

RESOLVED DUPLICATE of bug 34294
7 years ago
7 years ago

People

(Reporter: james, Unassigned)

Tracking

10 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 595729 [details]
box-absolute.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.46 Safari/535.11

Steps to reproduce:

Other browsers tested:
     Safari 5: OK
  Chrome 17: OK
     IE 7/8/9: ?

Test page: http://dl.dropbox.com/u/175535/box-absolute.html

div#container { position: relative; display: box; }
> div#overlay { position: absolute; }


Actual results:

div#overlay is rendered with positioning and dimensions relative to document


Expected results:

Should be relative to div#container
There is no display:box, and no plans for anything like that. 

display:-moz-box and display:-webkit-box are completely different things.  The former is a XUL box, the latter is an early draft of the CSS3 flexbox specification.  They have fairly different design goals and completely different behavior.  It's a bit unfortunate that the naming is similar.

There are no plans to allow absolute positioning inside XUL boxes.

Of course CSS3 flexboxes, once implemented, will allow it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 34294
(Reporter)

Comment 2

7 years ago
OK thanks that helps clear things up a bit more. I was under the impression that moz-box was based on XUL box, but is now targeting CSS3 flexbox. So if they are indeed completely separate things, there's a lot of misleading information out there that conflates them.

https://developer.mozilla.org/en/CSS/box-flex
http://hacks.mozilla.org/2010/04/the-css-3-flexible-box-model/
http://www.html5rocks.com/en/tutorials/flexbox/quick/
(most of the google results for css flexbox)

Is there any clear statement on progress towards a proper implementation of flexbox in Firefox?
> there's a lot of misleading information out there that conflates them.

Yes, there is...  People aren't very good at actually following what's going on in standards bodies, much less implementations.  CSS3 flexbox uses totally different syntax from -moz-box in various cases (including not using the "box" display value), and has completely different behavior in many situations.

I've fixed the devmo documentation.

> Is there any clear statement on progress towards a proper implementation of flexbox in
> Firefox?

Bug 666041 has the progress.  I believe Daniel is hoping to land it in the next few weeks.
You need to log in before you can comment on or make changes to this bug.