[wikimo] Can't upload files on wiki.mozilla.org

VERIFIED FIXED

Status

Infrastructure & Operations
WebOps: Other
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: Ioana Chiorean, Assigned: solarce)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 595765 [details]
file to be added

Steps to reproduce:
1. Log into wiki.mozilla.org (my username: ioana.chiorean)
2. From left panel choose upload file.
3. Chose a file accepted as extension and size (Maximum file size: 32 MB (a file on your computer)Permitted file types: gz, tar, png, gif, jpg, jpeg, ppt, pdf, doc, xls, zip, ics, mp3, ogg, odt, odp, svg, ogv, oga. )
4
. Choose a Destination filename and upload file.

Expected result: 
File is uploaded without errors

Actual result:
File is not uploaded and the following error appears: File extension does not match MIME type.
Which page are you trying to upload the file to?
Component: Server Operations → Server Operations: Web Operations
(Reporter)

Comment 2

6 years ago
I was not using any specific page . 

I just want to upload some images to be used for example in the Browser technologies beta test pages:
https://wiki.mozilla.org/index.php?title=QA/Fennec/Milestones/10.0/RC_1

or Romanian Community page:
https://wiki.mozilla.org/Romania

but is not related to the pages. 

Also , the upload was working OK for me before the zimbra problem, somewhere in the first week of December

Comment 3

6 years ago
I also encountered this problem trying to upload a screenshot with png extension. I was not trying to upload it to some specific page either.

Comment 4

6 years ago
I was able to upload that without issues:

https://wiki.mozilla.org/File:Failed_tests.png

'file' confirms it really is a PNG:
[jakemaul@JakeBook ~]$ file failed\ tests.png 
failed tests.png: PNG image, 720 x 1280, 8-bit/color RGB, non-interlaced


I'm not sure what could be wrong here. What OS are you two on? If Windows, can you make sure the file doesn't have a hidden extension that might be mucking things up?

Zimbra and wikimo aren't tied together in any meaningful way, so that should be irrelevant. The only way I can see that possibly being a concern is if you got the file over email and Zimbra somehow mucked up the MIME type or otherwise mangled the file or filename.


Is it just this specific file that you can't upload, or all files? It would be good to test a wide variety of file types if this is not an isolated incident.

I'm going to kick this bug over to the desktop support team... I think we've got a client-side issue of some kind, since I can't reproduce and the wikimo upload log shows plenty of success uploading files:

https://wiki.mozilla.org/Special:Log/upload

I'll stay CC'd though in case someone raises server-side concerns.
Assignee: server-ops → desktop-support
Component: Server Operations: Web Operations → Server Operations: Desktop Issues
QA Contact: cshields → tfairfield
Desktop can't help here. Reporters are in Romania, working for Softvision (QA contractors).
Assignee: desktop-support → server-ops
Component: Server Operations: Desktop Issues → Server Operations: Web Operations
QA Contact: tfairfield → cshields

Comment 6

6 years ago
I can't upload any files...
I am using W7 same system that worked before. Unfortunatelly all mobile team (6 people ) working as QA for Firefox can't upload and this issues is blocking our work when we have to share things .. 
I check the extensions.. are ok :(
Can someone attach one of the files you are getting rejected to this bug?  without altering the filename.

thanks

Comment 8

6 years ago
Hi,
you can find it in the attachment .. I've added at the beginning.
Ahh I see that now, and I see that jake was able to upload that file..  hrm..
(Assignee)

Updated

6 years ago
Assignee: server-ops → bburton
(Assignee)

Comment 10

6 years ago
Is there a convenient time tomorrow where you could get on Vidyo and do some screensharing, so I can watch live and help troubleshoot your issue?

Thanks
Status: NEW → ASSIGNED
(Reporter)

Comment 11

6 years ago
Sorry for the delay. I am in CET+1 timezone, PST +10. let me know when it suits our schedule.
(Reporter)

Comment 12

6 years ago
Here is a screen video: screencast.com/t/wSQKp5X0Vhcq
The video is a bit slow, my machine work better, not so slow
(Assignee)

Comment 13

6 years ago
I just wanted to confirm a couple things.

1. Multiple people are affected? Are they all in the same location? If so, what's the IP there? You can tell from going to http://www.icanhazip.com/
2. Are you also using Firefox to test the upload? If so, what version? Have you tried other builds of FF? Have you tried Chrome or IE?

Thanks!
(Reporter)

Comment 14

6 years ago
1. Yes, multiple people from Softvision team -  Contractor from Romania. 
IP: 188.27.147.153
but I encounter this also at home, I will reply while at home to see the IP.

2. We use W7 and Ubuntu, on Firefox Nightly and FF10 released.
Also doesnțt work on Chrome nor IE9.
(Assignee)

Comment 15

6 years ago
Thanks for the info, can you visit http://www.icanhazip.com/ , take note of the IP and then test another upload "today" and I'll look at the web logs as soon as I see your update to this bug and try to determine what's going.

Thanks!
(Reporter)

Comment 16

6 years ago
Hi. 
My IP again: 188.27.147.153 and still not able. 
I did not manage to do it in 03/05. If I can repeat test today or tomorrow, please ping the bug.
(Assignee)

Comment 17

6 years ago
Any day is fine, just confirm your IP before you do the upload, then note the IP, time, and name of the file in this bug

Thanks
(Assignee)

Comment 18

6 years ago
I wanted to check on this, is it something you can do tomorrow, around 8am PST GMT -8?
(Reporter)

Comment 19

6 years ago
Yes, I am available at this hour..
Component: Server Operations: Web Operations → Talkback Server & Webtool
(Assignee)

Comment 20

6 years ago
If you can, please repeat the test steps now or as soon as you see this.

Thanks
(Reporter)

Comment 21

6 years ago
I have tried to upload the file , right now. Same error.
(Assignee)

Comment 22

6 years ago
When you visit http://www.icanhazip.com/ is your IP still 188.27.147.153?

What is the name of the file you tried to upload?
(Reporter)

Comment 23

6 years ago
Yes, IP 188.27.147.153
File name - failed tests.png
I tried uploading this png file: http://i.imgur.com/hBC48.png
My IP: 88.152.97.156
File name: sumo-logo-small
(Assignee)

Updated

6 years ago
Summary: Can't upload files on wiki.mozilla.org → [wikimo] Can't upload files on wiki.mozilla.org
(Assignee)

Comment 25

6 years ago
[bburton@mradm02 ~]$ sudo issue-multi-command generic grep 188.27.147.153 /var/log/httpd/wiki.mozilla.org/*2012-03-21* &> /tmp/wmo.debug.txt
(Assignee)

Comment 26

6 years ago
I've found this happens if you don't end the filename with the same extension as the filename you're uploading.  These must match.

See https://skitch.com/solarce/8t58h/upload-file-mozillawiki for an image of what is needed.

Please attempt again and ensure it matches, and it should work nicely.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 27

6 years ago
True, this works fine now. Thanks for the support and time to investigate it .

Regards,
Ioana Chiorean
Status: RESOLVED → VERIFIED

Updated

6 years ago
Component: Talkback Server & Webtool → Server Operations: Web Operations
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.