Closed Bug 725692 Opened 10 years ago Closed 9 years ago

[One Mozilla] Code blog.mozilla.com Wordpress Theme

Categories

(Websites Graveyard :: blog.mozilla.org, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: christine.brodigan, Assigned: craigcook)

References

(Blocks 1 open bug, )

Details

Craig,

Assigning to you to be developed once design is completed by Ty in Bug 720579

Thanks!
also, this will include the new blog.mozilla.com landing page :-)

*1 landing page
*1 interior blog theme
We might have to discuss how Craig can build a theme this time that will be flexible enough to be used across the different "official" Mozilla blogs. The last time, the main theme was not made for that, resulting in many one-offs down the road. If we avoid that this time, we can have a theme that both preserves common assets across these blogs and gives the blog owners plenty of freedom for customization (with sidebar widgets and such), too.
+1 - this would be very helpful in offsetting the need for a roll-up.
Blocks: 726076
OK, Craig, let's proceed with having you take a first pass at setting up a vanilla theme, here are some details:

- Take grid/less from http://www.seanmartell.com/test_blog/
- 3 column approach (left big, middle smaller, right smallest)
- incorporate space for any Mozilla users to have customization (likely in the "right smallest" column)
- incorporate space for standard One Mozilla assets (universal social sharing, RSS, sign-up for Mozilla email)

I have this in for 1.7, but can move to 1.8

We'll make the design bug 720579 dependent on this.
Target Milestone: 1.9 → 1.7
Blocks: 720579
No longer depends on: 720579
Priority: -- → P1
Blocks: 727486
Blocks: 724931
Blocks: 730724
Craig, Looks AWESOME!

Ty is putting a bit of polish on the theme and will ship assets by the end of this week via Bug 720579.

Once you've finalized (early next week?) and the plugins are approved, we'll need one last security review. Then we'll apply this theme to 12 blogs that I'm tracking (4 are new).

My assumption is that at that point, we will not need to go through secreview unless there is a request for customization (plugins not design - design still needs to go through PR and Creative Teams for review).
Duplicate of this bug: 548242
Craig, here are the final PSDs with the polished assets:

http://mozilla.tyflanagan.com/artwork/MozOrg_Redesign/Moz_BlogTemplate_PSDs.zip

Can you shoot to have this complete for QA & secreview by Wednesday, March 7, 2011? If not, what is a more reasonable date?
(In reply to mcbmoz from comment #7)

> Can you shoot to have this complete for QA & secreview by Wednesday, March
> 7, 2011? If not, what is a more reasonable date?

A more reasonable date would be one in the future ;) I kid! Typos are funny!

The design changes are pretty minor, and there's just a bit of general testing and tidying left to do, so code freeze Wednesday should be no problem.
Ha! Thanks Craig :-) Looking forward to this.
Blocks: 733154
Blocks: 733156
Blocks: 733157
Blocks: 733159
Blocks: 733161
Blocks: 733164
Blocks: 733166
Blocks: 733167
Blocks: 733170
Blocks: 733171
Blocks: 733174
Blocks: 733177
Blocks: 733420
Friendly nudge, got a final pass ready for us to review and move to secreview?
Just updated the other bug with a link to the git repo (https://github.com/craigcook/One-Mozilla-blog).

I'm sure we'll find a few more code tweaks and cleanup in the next few days, but I'm pretty confident in calling this a 1.0 release. 

Should we resolve this so it stops blocking bug 733420? And maybe that bug in turn should block the various deployment bugs (can't push to prod or apply to blogs until we get the all-clear on security).
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Websites → Websites Graveyard
Product: Websites Graveyard → Websites
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.