Firefox hangs on repeated reload of https://github.com/explore

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Vince, Unassigned)

Tracking

10 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.106 Safari/535.2

Steps to reproduce:

I open a tab to github, login then proceed click a combination of the github logo in the top-right corner, my login name, or the "explore" link in the top panel.





Actual results:

After some iterations of clicking these links the browser hangs. System monitor reports firefox is running at 99% CPU.

This also occurs using firefox -safe-mode with all options checked.

inxi output:


System:    Host: muon Kernel: 3.2.3-2.fc16.x86_64 x86_64 (64 bit) Desktop: Gnome 2.32.0 Distro: Fedora release 16 (Verne)
Machine:   Mobo: ASUSTeK model: P6T version: Rev 1.xx Bios: American Megatrends version: 0904 date: 11/12/2009
CPU:       Quad core Intel Core i7 CPU 920 (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) 
           Clock Speeds: 1: 1600.00 MHz 2: 2668.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz 5: 1600.00 MHz 6: 1600.00 MHz 7: 1600.00 MHz 8: 1600.00 MHz
Graphics:  Card: nVidia G84 [GeForce 8600 GT] 
           Fedora X.org: 1.11.3 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1680x1050@59.9hz 
           GLX Renderer: Gallium 0.4 on NV84 GLX Version: 2.1 Mesa 7.11.2
Audio:     Card: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.24
Network:   Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169 
           IF: p34p1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1000.2GB (6.5% used) 1: /dev/sda WDC_WD1001FALS 1000.2GB 
Partition: ID: / size: 50G used: 9.1G (19%) fs: rootfs ID: / size: 50G used: 9.1G (19%) fs: ext4 
           ID: /boot size: 497M used: 97M (21%) fs: ext4 ID: /home size: 424G used: 52G (13%) fs: ext4 
           ID: swap-1 size: 8.39GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 47.5C mobo: 43.0C gpu: 55.0 
           Fan Speeds (in rpm): cpu: 1962 psu: 0 sys-1: 0 sys-2: 0 
Info:      Processes: 221 Uptime: 1:47 Memory: 1129.1/5960.9MB Client: Shell inxi: 1.7.28 



Expected results:

Browse github without problem.
(Reporter)

Comment 1

6 years ago
Resolved the issue by deleting my user profile as per these instructions:

http://support.mozilla.org/en-US/kb/Managing-profiles#w_removing-a-profile
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Comment 2

6 years ago
I am having the same problem. Removing my profile did not work, it also occurs with a fresh profile, in safe mode, or without hardware acceleration.

Sometimes Firefox just crashes and opens a crash report form, sometimes it locks up and starts using 99% CPU. I use FF 10 on Linux as well.
(Reporter)

Comment 3

6 years ago
Yup. Removing my profile did not work. I also disabled hardware acceleration. Soemtimes it alsoi just crashes, but mainly just hangs.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

6 years ago
FF10 works OK on my home setup, inxi output:

System:    Host: gluon Kernel: 3.2.3-2.fc16.x86_64 x86_64 (64 bit) Desktop: Gnome Distro: Fedora release 16 (Verne)
Machine:   System: Dell product: Studio 540
           Mobo: Dell model: 0M017G version: A00 Bios: Dell version: 1.1.3 date: 08/25/2009
CPU:       Quad core Intel Core2 Quad CPU Q8200 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3) 
           Clock Speeds: 1: 2003.00 MHz 2: 2003.00 MHz 3: 2003.00 MHz 4: 2003.00 MHz
Graphics:  Card: ATI RV730XT [Radeon HD 4670] 
           Fedora X.org: 1.11.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD RV730 GLX Version: 2.1 Mesa 7.11.2
Audio:     Card-1: ATI RV710/730 driver: snd_hda_intel Sound: ALSA ver: 1.0.24
           Card-2: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel
           Card-3: Logitech QuickCam E2500 series driver: USB Audio
Network:   Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169 
           IF: p37p1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1250.3GB (36.1% used) 1: /dev/sda WDC_WD5000AAKS 500.1GB 
           2: /dev/sdb Hitachi_HDS72107 750.2GB 
Partition: ID: / size: 50G used: 7.8G (16%) fs: ext4 ID: /boot size: 497M used: 96M (21%) fs: ext4 
           ID: /home size: 640G used: 25G (4%) fs: ext4 ID: swap-1 size: 8.42GB used: 0.00GB (0%) fs: swap 
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 198 Uptime: 1 day Memory: 1500.9/5971.3MB Client: Shell inxi: 1.7.29 

I try to get all the version numbers for the list of software dependancies for FF (e.g. xulrunner).  Maybe this is caused by some particular package ...
(Reporter)

Comment 5

6 years ago
Some additional info. Inspecting firefox using strace, last few lines before it hangs are:

poll([{fd=5, events=POLLIN}, {fd=4, events=POLLIN}, {fd=7, events=POLLIN|POLLPRI}, {fd=22, events=POLLIN}, {fd=21, events=POLLIN}, {fd=9, events=POLLIN|POLLPRI}, {fd=24, events=POLLIN}, {fd=18, events=POLLIN}], 8, -1) = 1 ([{fd=18, revents=POLLIN}])
read(18, "\372", 1)                     = 1
futex(0x7fa8a3a3864c, FUTEX_WAKE_OP_PRIVATE, 1, 1, 0x7fa8a3a38648, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_GT, 1}) = 1
futex(0x7fa8acdf48a0, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x7fa8a3a3868c, FUTEX_WAIT_PRIVATE, 3, NULL) = 0
ioctl(61, 0xc0406481, 0x7fffb5f1ab10)   = 0

ioctl(61, 0xc0406481, 0x7fffb5f1ab10)   = 0
(Reporter)

Comment 6

6 years ago
How I can reproduce the problem easily:

1. Launch Firefox in safe mode, checking all options to disable all features. 
2. Visit https://github.com/explore (no login required).
3. Repeatedly reload the page.
4. After a series of iterations (under 1m), Firefox hangs.

Maybe it's related to the media player in the "Changelog Podcast" section?
(Reporter)

Comment 7

6 years ago
Disabling javascript (Preferences > Contentm > uncheck "enable javascript") appears to solve the issue, or at least delays the hang beyond a few minutes.

(In reply to Vince from comment #6)
> How I can reproduce the problem easily:
> 
> 1. Launch Firefox in safe mode, checking all options to disable all
> features. 
> 2. Visit https://github.com/explore (no login required).
> 3. Repeatedly reload the page.
> 4. After a series of iterations (under 1m), Firefox hangs.
> 
> Maybe it's related to the media player in the "Changelog Podcast" section?
(Reporter)

Updated

6 years ago
Summary: Firefox hangs when browsing github → Firefox hangs on repeated reload of https://github.com/explore

Comment 8

6 years ago
For me it happens on all pages of Github, not just explore.

I've upgraded to 10.0.1 today. Haven't tested yet if the problem is fixed.
(Reporter)

Comment 9

6 years ago
I tried it with the nightly build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-13.0a1.en-US.linux-x86_64.tar.bz2

Still hangs on github :(
(Reporter)

Comment 10

6 years ago
(In reply to Albert from comment #8)
> For me it happens on all pages of Github, not just explore.
> 
> I've upgraded to 10.0.1 today. Haven't tested yet if the problem is fixed.

Hi Albert,

I have tentatively have solved the issue.

I installed the nvidia driver, disabling the nouveau driver as described here:

http://www.if-not-true-then-false.com/2011/fedora-16-nvidia-drivers-install-guide-disable-nouveau-driver/

So far so good. I'll report back if FF hangs again.

Comment 11

6 years ago
At me the issue also happens when hardware acceleration is off so the graphics driver isn't to blame. Upgrading to 10.0.1 did not help.
(Reporter)

Comment 12

6 years ago
I also had the issue when hardware acceleration was off, which makes me suspect that the video driver may still be the cause, just not at the level of hardware acceleration.  This is just speculation of course.

(In reply to Albert from comment #11)
> At me the issue also happens when hardware acceleration is off so the
> graphics driver isn't to blame. Upgrading to 10.0.1 did not help.

Comment 13

6 years ago
But a graphics driver can't make Firefox use more CPU? By the way, Chromium works fine.

I basically need nouveau as I'm helping the nouveau people with some reverse-engineering work. My desktop runs nouveau as well and github works just fine on there.
(Reporter)

Comment 14

6 years ago
(In reply to Albert from comment #13)
> But a graphics driver can't make Firefox use more CPU? By the way, Chromium
> works fine.
> 
> I basically need nouveau as I'm helping the nouveau people with some
> reverse-engineering work. My desktop runs nouveau as well and github works
> just fine on there.

Thanks for the info. I have an ATI card on the working setup, so thought maybe it was a nouveau problem. Your set up rules that out.

Comment 15

6 years ago
Firefox 10.0 has been crashing and hanging for me on various github pages, also.

Running Linux Mint 12 64-bit with Firefox 10.0. Default Gnome-based desktop, Intel video acceleration.

Comment 16

6 years ago
I have this problem as well, Firefox hangs and crashes when browsing GitHub.

My system is:

Arch Linux x86-64
Firefox 10.0.1
Linux 3.2.5 / nouveau

Comment 17

6 years ago
Arch, Fedora and Mint users so far. NVidia, AMD and Intel. Apparently the problem is Linux-only but not related to any specific distro.

Vince said he solved it by using the nvidia driver instead of nouveau. Perhaps it's related to Mesa? "Use the proprietary driver" is not an option for Intel users, so even if it's Mesa-related it still needs fixing.
(Reporter)

Comment 18

6 years ago
I can confirm that since installing the NVIDIA driver on 2012-02-13 I have no more hangs with github. However, I now have reproducible crashes. Particular site that consistently crashes the browser is:

http://linux.koolsolutions.com/2009/04/24/tip-how-to-check-which-video-driver-is-your-x-server-using/

Launching in safe mode  with all options checked alleviates the crash.  Leaving options 3, 4 or 5 unchecked causes crashes almost every time. Hardware acceleration was disabled for all attempts.

Not sure if this should be a separate bug.

Comment 19

6 years ago
I use nouveau and can't get that page to crash. So please open a seperate bug for it.

Comment 20

6 years ago
Firefox 10.0.2 seems to have fixed this bug for me. Let's close it?

Comment 21

6 years ago
I was able to get Firefox 10.0.2 to hang (with 100% on single CPU) on github just by surfing around on github for about 2 minutes. I have to use github on a daily basis, and I lose all my tabs when this happens. I'm stuck using a different browser until this is fixed, though I prefer Firefox.

Just for kicks, I restarted Firefox (after killing and opening it again) with all add-ons disabled. Same story. Took about 2 or 3 minutes to hang just clicking around on various github pages.

Comment 22

6 years ago
Strange. My Firefox does not crash or hang anymore and I've used Github extensively today.
(Reporter)

Comment 23

6 years ago
Same here, seems to work now. I assume an update of some package since then has fixed the issue. I am using Firefox 10.0.1.

Comment 24

6 years ago
Firefox 10.0.2 still hangs when I go to Github.

Comment 25

6 years ago
Is this still an issue in Firefox 11?

it hasn't hanged yet here with Firefox 11.

Comment 26

6 years ago
10.0.2 still crashes once in a week or so, but doesn't seem related to Github anymore.

Comment 27

6 years ago
I've been using Firefox 11.0 for about a week without issues. Today, on github, just browsing source code, the browser locked up with 100% cpu on one core. I had to kill it.

Comment 28

6 years ago
I'm using the nouveau drivers for my nvidia card. Might be related?
If any of you are still seeing this issue, could you confirm that the issue is reproducible in safe mode (or with a clean profile) with the latest Nightly:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/

FTR, this works for me on Ubuntu 11.10 with the latest Nightly (using vince's steps from comment 6)

(In reply to Vince from comment #18)
> Not sure if this should be a separate bug.

yes, please file a separate bug for that. It's easier to track.


(In reply to Stephen A. Goss from comment #28)
> I'm using the nouveau drivers for my nvidia card. Might be related?

Could you post your graphics content from about:support?

Comment 30

6 years ago
Removing myself from CC list, as I don't have any github crash anymore with Linux Mint 12 / nouveau graphics driver / Firefox 11.

Comment 31

6 years ago
(In reply to Virgil Dicu [:virgil] [QA] from comment #29)

> (In reply to Stephen A. Goss from comment #28)
> > I'm using the nouveau drivers for my nvidia card. Might be related?
> 
> Could you post your graphics content from about:support?

Adapter Description : nouveau -- Gallium 0.4 on NVA8
Driver Version : 2.1 Mesa 7.11
WebGL Renderer : nouveau -- Gallium 0.4 on NVA8 -- 2.1 Mesa 7.11
GPU Accelerated Windows : 0

Comment 32

6 years ago
I am unable to reproduce bug on Firefox Nightly build after several minutes of loading various github pages (on Firefox 11 in safe-mode this reliably crashes/freezes within a minute or two for me.)
(In reply to Stephen A. Goss from comment #32)
> I am unable to reproduce bug on Firefox Nightly build after several minutes
> of loading various github pages (on Firefox 11 in safe-mode this reliably
> crashes/freezes within a minute or two for me.)

Thanks for checking, Stephen. Seems that whatever issue that was triggering this for you was fixed after Firefox 11. At a quick view, bug 696636 seems to involve some mesa linux issues-that was fixed in F 12. Not sure if related though.

Maybe Firefox 12 will prove to be more reliable from this point of view. You can already download the beta version. It will reach release in about two weeks. Hope this helps for the moment.

FTR. I can't see any issues here with F11 either on github. Nvidia and Ubuntu 11.10.

Comment 34

6 years ago
Hm, not sure its fixed. Here's a link to one of my crash reports:

https://crash-stats.mozilla.com/report/index/bp-ce93ae40-61c5-4e3e-b914-2656b2120405

looks WebGL related.

Under about:support in Firefox Nightly:

WebGL Renderer : Blocked for your graphics driver version. Try updating your graphics driver to version Mesa 8.0 or newer.

So, maybe I'm not getting the crash simply because WebGL is disabled on Firefox Nightly due to Mesa version mismatch.
(In reply to Stephen A. Goss from comment #34)
> Under about:support in Firefox Nightly:
> 
> WebGL Renderer : Blocked for your graphics driver version. Try updating your
> graphics driver to version Mesa 8.0 or newer.
> 

If the driver is only blacklisted in Nightly and not in F11, that might explain it. There were a few bugs related to incorrect blacklist recently for some drivers- fixed on Firefox side in 11 and 12. I wouldn't be surprised if one of them would be the culprit here. This might also explain why the original issue got resolved starting with F11 for a few folks here.

Comment 36

6 years ago
Nouveau WebGL is fine here.

WebGL Renderer: nouveau -- Gallium 0.4 on NV86 -- 2.1 Mesa 8.1-devel (git-897af1d oneiric-oibaf-ppa)

I upgraded Mesa to 8.x with this PPA: https://launchpad.net/~oibaf/+archive/graphics-drivers

Comment 37

6 years ago
Perhaps the Mesa upgrade fixed the bug for me, instead of Firefox. In that case it's indeed a good idea to have Mesa 7.11 and before blacklisted - or at least mesa 7.x with nouveau as WebGL renderer.

Comment 38

6 years ago
Disabling WebGL in about:config stopped the crashing. I upgraded my mesa drivers with the ppa Albert linked to, turned WebGL back on and Firefox 11 now appears stable on github.com.

Comment 39

6 years ago
I've been using Firefox 11 with nouveau recently (Linux 3.3.1) and browsing github and other sites, so far so good, no crashes here anymore.

Comment 40

6 years ago
Should we close this bug now? I have been using Firefox 12 for a while and I have not experienced a single hang again.

And yes, I've been using GitHub a lot.

Comment 41

6 years ago
Is there anyone still with stability/hang problems?
(In reply to Diego Viola from comment #40)
> Should we close this bug now? I have been using Firefox 12 for a while and I
> have not experienced a single hang again.
> 
> And yes, I've been using GitHub a lot.

I'll close this for the moment. Nice to see this got resolved. Thanks for the prompt replies, everyone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.