Last Comment Bug 725723 - rename reftests/flexbox/ to reftests/box
: rename reftests/flexbox/ to reftests/box
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on:
Blocks: css3-flexbox
  Show dependency treegraph
 
Reported: 2012-02-09 10:27 PST by Daniel Holbert [:dholbert]
Modified: 2012-02-14 02:33 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch ("hg mv flexbox box" & update reftest.list) (3.63 KB, patch)
2012-02-09 10:40 PST, Daniel Holbert [:dholbert]
dbaron: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-02-09 10:27:07 PST
The directory /layout/reftests/flexbox/ currently contains 4 tests for -moz-box.

I'd like to rename this to reftests/box/ because:
 - it's for "display: [-vendor-]box", as compared to "display: [-vendor-]flexbox"
 - we already have 2 other directories of -moz-box related tests in "box"-themed folders:
     reftests/box-ordinal/
     reftests/box-properties/

and of course we're going to need a place to put "display: [-vendor-]flexbox" tests, and I'd like that to be in reftests/flexbox.  (In my local patches, I've been sticking them in reftests/css-flexbox, but IMHO it'd be madness to have both "flexbox" and "css-flexbox" reftest directories.)
Comment 1 Daniel Holbert [:dholbert] 2012-02-09 10:40:59 PST
Created attachment 595812 [details] [diff] [review]
patch ("hg mv flexbox box" & update reftest.list)

Here's the patch for the rename. It's just a hg mv plus an update to reftest.list.

(I used the newer (I think?) commenting convention from that reftest.list file, with a slightly more descriptive comment than just the quoted directory name)
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-02-13 14:21:35 PST
Comment on attachment 595812 [details] [diff] [review]
patch ("hg mv flexbox box" & update reftest.list)

r=dbaron
Comment 3 Daniel Holbert [:dholbert] 2012-02-13 14:38:00 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/6711ced03ad3
Comment 4 Marco Bonardo [::mak] 2012-02-14 02:33:15 PST
https://hg.mozilla.org/mozilla-central/rev/6711ced03ad3

Note You need to log in before you can comment on or make changes to this bug.