The default bug view has changed. See this FAQ.

getaddrinfo and related functions are not wrapped since bug 683127 part 2

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox10 unaffected, firefox11 fixed, firefox12 fixed, firefox13 fixed, firefox-esr10 unaffected)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 595814 [details] [diff] [review]
Properly wrap getaddrinfo and related symbols (regression from bug 683127 part 2)
Attachment #595814 - Flags: review?(ted.mielczarek)
(Assignee)

Updated

5 years ago
Blocks: 683127
(Assignee)

Updated

5 years ago
status-firefox-esr10: --- → unaffected
status-firefox10: --- → unaffected
status-firefox11: --- → affected
status-firefox12: --- → affected
status-firefox13: --- → affected

Updated

5 years ago
Attachment #595814 - Flags: review?(ted.mielczarek) → review+

Updated

5 years ago
Attachment #595814 - Flags: approval-mozilla-beta?
Attachment #595814 - Flags: approval-mozilla-aurora?

Comment 2

5 years ago
https://hg.mozilla.org/mozilla-central/rev/e119583f8b06
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 595814 [details] [diff] [review]
Properly wrap getaddrinfo and related symbols (regression from bug 683127 part 2)

Needed to fix the crashes and use the thread-safe versions.
Attachment #595814 - Flags: approval-mozilla-beta?
Attachment #595814 - Flags: approval-mozilla-beta+
Attachment #595814 - Flags: approval-mozilla-aurora?
Attachment #595814 - Flags: approval-mozilla-aurora+

Comment 4

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/17659ede539f
https://hg.mozilla.org/releases/mozilla-beta/rev/11c4cf64aa63
status-firefox11: affected → fixed
status-firefox12: affected → fixed
status-firefox13: affected → fixed

Updated

5 years ago
Duplicate of this bug: 719741
You need to log in before you can comment on or make changes to this bug.