Last Comment Bug 725903 - PathExtentsToMaxStrokeExtents needs to take a transform argument
: PathExtentsToMaxStrokeExtents needs to take a transform argument
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on: 725897
Blocks: 614732
  Show dependency treegraph
 
Reported: 2012-02-09 17:48 PST by Jonathan Watt [:jwatt]
Modified: 2012-02-10 19:47 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (7.33 KB, patch)
2012-02-09 17:50 PST, Jonathan Watt [:jwatt]
longsonr: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] 2012-02-09 17:48:53 PST
PathExtentsToMaxStrokeExtents currently just uses GetCanvasTM() to figure out how much to expand the stroke by. When calling GetBBoxContribution, this can mean that we get the expansion very wrong, since the transform to the canvas is not usually what we want.

The kill-covered-regions patches in bug 614732 switch to using GetBBoxContribution in user space (instead of canvas space) as part of figuring out the covered region, and some tests fail as a result of PathExtentsToMaxStrokeExtents using the canvas TM.
Comment 1 Jonathan Watt [:jwatt] 2012-02-09 17:50:54 PST
Created attachment 595925 [details] [diff] [review]
patch

This patch also depends on the changes to test_bounds.html in bug 725897.
Comment 2 Jonathan Watt [:jwatt] 2012-02-10 03:05:09 PST
Passed Try.
Comment 3 Ed Morley [:emorley] 2012-02-10 19:47:32 PST
https://hg.mozilla.org/mozilla-central/rev/6d5192687c91

Note You need to log in before you can comment on or make changes to this bug.