Filters all lost between sessions

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: trudelle, Assigned: gayatrib)

Tracking

({dataloss})

Trunk
x86
Windows 98
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using today's NS build on Win98:

Create several new message filters.
Click OK.
<nothing happens>
click close
<dialog disappears>
open filters dialog again to verify the filters are there.
<they are>
Quit app.
Launch app.
open filters dialog again to verify the filters are there.
<they are not there, list is empty>
(Reporter)

Comment 1

18 years ago
Nominating for nsdogfood
Keywords: nsdogfood

Comment 2

18 years ago
This is working for me on Win 2000.  Laurel, are you able to reproduce this? We
have a couple of bugs out there about OK buttons in dialogs (Address Picker in
Compose Window, news property dialog) not working. This might be related.

Updated

18 years ago
QA Contact: esther → laurel

Comment 3

18 years ago
No my new filters are hanging around from session to session using mar21 trunk
with win98.  Will try some more...
(Reporter)

Comment 4

18 years ago
I just tried to check the filter file itself, and found that N6 mail is sharing
the Messenger 4.x mail directory for my NS account.  Is that normal? I have
filters that are working in 4.x that don't even show up in N6. 

Comment 5

18 years ago
No, you shouldn't "normally" be sharing the 4.x mail directory.  How and when
did you create/migrate this profile?  

Some filter stuff which would work in 4.x doesn't work in 6.x because some
criteria choices are not implemented; things like Date, custom/arbitrary
headers, and some more that escape me right now.

I haven't reproduced the disappearing filters act with the commercial trunk
using win98, mar21 build.  We really haven't had another good build to use
since, but will  keep an eye out in next builds.
(Reporter)

Comment 6

18 years ago
I don't know how old the profile is, I've been installing and running the latest 
build every day for many months.  I'll start over with a new profile, and try 
this again.  

Comment 7

18 years ago
Peter, I'm marking this dogfood- unless it can be reproduced without sharing
between 6.x & 4.x.  That is not a supported configuration.  If this turns into a
bug about migration causing that situation then the dogfood should come back.
Keywords: nsdogfood → nsdogfood-
(Reporter)

Comment 8

18 years ago
I'm sure it was a migration problem at some time, as I have never manually set
the path where these things should be stored.  I verified with today's build
that I can create and save new message filters.  However, my newly migrated
profile didn't contain any of my 4.x filters, is that a known defect?

Comment 9

18 years ago
I'm using 2001-03-28-09 commercial trunk with win98 and I remigrated  -- all my
filters came through and executed.  Are you using IMAP or POP?  

Is the filters.dat file actually present in the new 6.x migrated directory or
are they not displayed in the UI?
(Reporter)

Comment 10

18 years ago
It is present, but source filter file was at some point changed to read-only,
which propagated to migrated file.  Seems to work when I make it writable.  Odd
that it couldn't even read the filters until I did that though. 

Comment 11

18 years ago
Reproduced with 2001040904/Win2k.
New filters are lost if I restart Mozilla.

Comment 12

18 years ago
Still not happening for me with either old/migrated or new profile, commercial 
trunk build win98, apr10.

Comment 13

18 years ago
Adding dataloss keyword.

WFM on 2001051720 Win2k.
Keywords: dataloss

Comment 14

18 years ago
I can't reproduce this on the 5/20 build on Win 2K. Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 15

18 years ago
Marking verified worksforme
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.