Intermittent 500 errors reported to Google Group

RESOLVED FIXED in Builder 1.0

Status

addons.mozilla.org Graveyard
Add-on Builder
P1
blocker
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: canuckistani, Assigned: zalun)

Tracking

unspecified
Builder 1.0
x86
Mac OS X

Details

Builder users occasionally report that builder throws a 500 error for them. The issue seems intermittent, unsure if we log and track 500s.

The thread is here:

https://groups.google.com/forum/#!topic/mozilla-labs-jetpack/lyeSepiyxWE

As the team closes in on 1.0, should we be paying more attention to these types of errors?
I had my (persistent) 500 error on my dashboard fixed by them running fix_packages on the database. Then I broke it again and got my 500 error back.

Updated

7 years ago
Depends on: 724766
I have successfully figured out a path-to-reproduce that is 100% accurate, every time. Open this in many tabs, and prepare to watch the app explode: https://builder.addons.mozilla.org/addon/new/

The resulting error puts the app in a completely unusable state. This is a blocker and will prevent 1.0 release on Wednesday February 15th. Consider the resolution of this bug THE priority for the entire team --> I would suggest a night and day effort until this is resolved.
Assignee: nobody → zaloon
Severity: normal → blocker
Priority: -- → P1
Target Milestone: --- → Builder 1.0

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.