Closed Bug 726160 Opened 10 years ago Closed 10 years ago

Update /Technology for Firefox 11

Categories

(www.mozilla.org :: General, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lmesa, Assigned: jlong)

References

(Depends on 1 open bug)

Details

(Whiteboard: r=102688,102875,102910 b=trunk)

Attachments

(1 file)

Update Content of /Technology per content in https://pmm.etherpad.mozilla.org/30

Currently working on content--will post here when complete.
Depends on: 726161
Depends on: 730326
Assignee: lmesa → lforrest
Here's another one for Fx11. 

Laura - when will these details be finalized?
Assignee: lforrest → jlong
Target Milestone: --- → 1.10
So weird--I thought I updated this bug last week:  here are all the changes:

https://docs.google.com/document/d/1fOjooNqbpOboJnR6sfJmD0KcF4DTU75VuGKqe8UXGdA/edit
Hi James - there are some new demos in the attached document that may introduce some complexities onto this page. Take a look - this is for the launch next Tuesday.
This is really confusing. The document doesn't tell me exactly which sections are added, updated, or removed. Please include these details in the document.
Priority: -- → P1
(In reply to James Long (:jlongster) from comment #4)
> This is really confusing. The document doesn't tell me exactly which
> sections are added, updated, or removed. Please include these details in the
> document.

I'm sorry it was confusing--I've just worked to clean it up and add those details.  

is it clearer now?
Yep, that helps a lot, thanks!

The "Innovating with HTML5" section has a "Forms" blurb, which is partly what confused me too.
Oh, damn--you're right.  

Too many forms!  I meant the forms in Innovating like you mention above, not the formData one. Arg, sorry about that.
Most of this has been done. A few issues:

* For the form demo, try and submit it and watch what happens when the error pops up. The demo slides away when the mouse hovers over the error message, but comes back if it hovers over the block. I have no idea how to fix this, can you ping someone who makes demos?

* The page inspector video isn't starting automatically for some reason

* The 3d transformation demo isn't working exactly like the provided one. The provided one is tilted to the side and this one isn't. I copied the html/css and only made tiny tweaks but can't figure why it doesn't match exactly. Can whoever made the demo look at the source here and try to help out?
(In reply to James Long (:jlongster) from comment #8)
> Most of this has been done. A few issues:
> 
> * For the form demo, try and submit it and watch what happens when the error
> pops up. The demo slides away when the mouse hovers over the error message,
> but comes back if it hovers over the block. I have no idea how to fix this,
> can you ping someone who makes demos?
> 
> * The page inspector video isn't starting automatically for some reason
> 
> * The 3d transformation demo isn't working exactly like the provided one.
> The provided one is tilted to the side and this one isn't. I copied the
> html/css and only made tiny tweaks but can't figure why it doesn't match
> exactly. Can whoever made the demo look at the source here and try to help
> out?

Adding Christian as he built the demos.  Christian, can you take a look?
The main one is the forms. We might have to re-work how the demo interaction works if the hovering doesn't work correctly with the error notifications.
Can I see this somewhere to see how it fails? I'd wager to guess it is a problem with the main rollover style.
Proposed to add a class to the article when focusing on the form or its fields to ensure the main highlight doesn't go away. 

The issue is as James said - now we just assume that people hover on and off the demos and don't do any interactions. That actually lessens our options to show off demos.

The 3D transform is OK this way.

The Tilt video works. no audio might have been the issue
Thanks Christian, the form demo is fixed with the hack to apply a special class.

These should be done. Laura, please review on http://www-dev.allizom.org/en-US/firefox/technology/
Whiteboard: r=102688,102875 b=trunk
Attached image Tilt Screenshot
Thanks James--the page looks really good and all the changes look nice. 

After looking at the video for tilt, however, I think its a bit too long and too small for the average person to understand or make sense of.  Instead, I think we should just put a screenshot.  I'm attaching that screenshot to this comment for use. 

Otherwise I think we're good to go.
final tweak are finished
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: qawanted
Resolution: --- → FIXED
Whiteboard: r=102688,102875 b=trunk → r=102688,102875,102910 b=trunk
pushed to production r102932
verified fixed http://www.mozilla.org/en-US/firefox/technology/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.