Status

MailNews Core
Backend
--
minor
VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: Zappa, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When browsing news number of unread messages in old threads, where no unread
messages
present, appears as negative numbers
I saw from -1 to -4

Comment 1

17 years ago
Reporter what build ID are you using? Have you tried with the latest nightlies?
Does that fix the problem?
(Reporter)

Comment 2

17 years ago
Build 2001032521 - still the same
appears when looking at big number of postings
found when i read fido via news server
i reported this bug since i think that this numbers calculated by mozilla

Comment 3

17 years ago
this may be an old bug coming back (or it never went away)?

http://bugzilla.mozilla.org/show_bug.cgi?id=29679

Do you see this when you create a new profile and add that same newsgroup?  Does 
this happen w/other newsgroups?
QA Contact: esther → stephend
I just marked all messages read and sorted by thread (partial steps from Lisa's
filing a long time back) and saw only Unread: 0 counts, but this may be server
specific or something.  Zappa, what newsgroup are you reading?  Can you provide
a log file if you're still experiencing this?  Steps for each platform to create
a logfile can be found at:
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap.  Please let
us know what you find.  Thanks.
(Reporter)

Comment 5

17 years ago
Negative unread number as I now can say for shure is server dependant and not
at any rate mozilla's bug but is the bug in servers I saw it on
I must apologize for wasting time - will do more sorough testing in the future
before posting the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Zappa, can you give us the reasons why this is server side?  I believe you, it
would just be nice to have a server log (or screenshots of a process running,
etc).  Thanks!
Alas I have no access to servers [:-(]
The reason for my opinion is that i initialy have been observing this
negative number when reading news groups from my favorite news server
Then I switched to original server for the news group (namely news.fido7.ru)
and discovered that all bad signs for which I originally blamed mozilla
were due to my first server. Now I regularily read same news groups from
originating server and observ no inconsistencies such as negative unread
number
Lately my first server behaves rather bad so I blame it for the bug.

If ou still may need some info i can make all logs and so which can be made from
client side only.

Regards,
Zappa 

Seth, David, can you think of any cases where we would produce such numbers,
client-side?
Zappa, if you can give us a log of your "bad" server, that would be great.  Thanks!
verified, per reporter's comments.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.