Motion JPEG should retain previous frame while drawing incoming frame

RESOLVED DUPLICATE of bug 625012

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 625012
6 years ago
6 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Reported from IRC. Loading a progressive JPEG on a current nightly is suboptimal.

After a frame is shown, the image is cleared and then the next frame is drawn (or the image is cleared when the next frame starts?). Essentially, this means that the closer a pixel is to the bottom of the image, the more time it spends being blank.

Chrome seems to do the right thing here. Either it's not doing any incremental display, or it's retaining the previous decoded frame as it displays the next frame.
(Reporter)

Comment 1

6 years ago
Blah. Using the wrong term -- not "progressive jpeg", but rather "motion jpeg".
Summary: Progressive JPEG should retain previous frame while drawing incoming frame → Motion JPEG should retain previous frame while drawing incoming frame
(Reporter)

Comment 2

6 years ago
And now I can find bug 625012!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 625012
You need to log in before you can comment on or make changes to this bug.