Flash object on sockshare.com not working if ABP is installed

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Bur, Unassigned)

Tracking

14 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120210 Firefox/13.0a1
Build ID: 20120210031150

Steps to reproduce:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120210 Firefox/13.0a1
Adblock Plus 2.0.4a.3409

ABP must be installed, but may be disabled or Firefox run in safe-mode. Open this video http://www.sockshare.com/file/6902291F4A29FDED (SFW home video from the zoo). Press play to load the flash object.


Actual results:

The flash object won't load. Just the site background is visible. Site information shows the flash object greyed-out.


Expected results:

Flash object should have been loaded and video been played.

This might be related to 723154, but it was said to file a new bug for new affected sites.

Comment 1

6 years ago
I can confirmed on latest Win32 Nightly build that I have the same problem with embedded flash videos on sockshare.com, the problem started when bug 90268 landed and the problem still occurs even after bug 723154 has been marked Resolved Fixed. Sockshare.com is the only site that I have come across that still has this problem when using the latest Dev build of Adblock Plus.

Tested with IE 8 and latest Google Chrome(Using ABP for Chrome) and this problem doesn't occur...

Note: I No longer have Scriptish installed, which I mentioned I was using in bug 723154 .
Blocks: 90268

Comment 2

6 years ago
I can confirm; user agent:

Mozilla/5.0
X11
Ubuntu
Linux
x86_64
rv
13.0a1
Gecko/20120215
Firefox/13.0a1

My addons are: ABP, Ghostery, and Globalmenu integration.
OP, you may want to add Linux to the platform list.
(Reporter)

Updated

6 years ago
OS: Windows 7 → All
Component: Untriaged → Plug-ins
Product: Firefox → Core
QA Contact: untriaged → plugins

Comment 3

6 years ago
Cannot reproduce, the video is OK for me.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

Shockwave Flash
File: NPSWF32.dll
Version: 11.1.102.62
Shockwave Flash 11.1 r102

Adblock Plus 2.0.3

Comment 4

6 years ago
(In reply to RNicoletto from comment #3)
> Cannot reproduce, the video is OK for me.
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
> 
> Shockwave Flash
> File: NPSWF32.dll
> Version: 11.1.102.62
> Shockwave Flash 11.1 r102
> 
> Adblock Plus 2.0.3

This bug# is specific to:

 Version: 	13 Branch 

Not: Fx11 betas or Fx12 Aurora builds

Comment 5

6 years ago
(In reply to rob64rock from comment #4)
> This bug# is specific to:
> 
>  Version: 	13 Branch 
> 
> Not: Fx11 betas or Fx12 Aurora builds

OPS... Sorry, I missed the flag.

OK, I can confirm the problem with latest nightly on Windows 7 6-bit.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

6 years ago
I can confirm too. Ubuntu Linux 11.10 x86-64, firefox 13.0a1 (2012-02-23)
(Reporter)

Comment 7

6 years ago
Works now on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120316 Firefox/14.0a1 with Adblock Plus 2.0.4a.3417.

So this should be set to resolved?

Comment 8

6 years ago
(In reply to Bur from comment #7)
> Works now on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120316
> Firefox/14.0a1 with Adblock Plus 2.0.4a.3417.
> 
> So this should be set to resolved?

Confirmed using latest Dev ABP 2.0.4a.3417 on video here:
http://www.sockshare.com/file/EA2062955D220935

This Bug should now be marked Resolved Fixed....
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

6 years ago
The bug appeared again with today's nightly (26-03-12). Updating to newest ABP dev build (3420) did not help.

Since the example video from the original comment got deleted here's a new link (still the same legal sfw pig video): http://www.sockshare.com/file/8D90DA954BEF29EC
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

6 years ago
I checked at my work computer (Win 7 32bit with ABP 2.0.3) and the problem appears there as well. So I set platform from x86_64 to x86.
Hardware: x86_64 → x86
(Reporter)

Updated

6 years ago
Version: 13 Branch → 14 Branch
(Reporter)

Comment 11

6 years ago
With build 14.0a1 (2012-03-30) it's working again.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME

Comment 12

6 years ago
(In reply to Bur from comment #11)
> With build 14.0a1 (2012-03-30) it's working again.

Confirmed on Windows XP too. ABP 2.0.4a.3420
You need to log in before you can comment on or make changes to this bug.