TestPlainTextSerializer fails to link

RESOLVED DUPLICATE of bug 717540

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 717540
6 years ago
4 months ago

People

(Reporter: TimAbraldes, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 596408 [details]
Mozconfig

I get this message when building m-c on Win7 without --disable-tests:
  TestPlainTextSerializer.obj : error LNK2019: unresolved external symbol __imp_JS_Assert referenced in function "public: __cdecl ScopedXPCOM::~ScopedXPCOM(void)" (??1ScopedXPCOM@@QEAA@XZ)
  TestPlainTextSerializer.exe : fatal error LNK1120: 1 unresolved externals

It seems like __imp_JS_Assert became a dependency when a MOZ_ASSERT was added to ScopedXPCOM::~ScopedXPCOM in this changset: https://hg.mozilla.org/mozilla-central/rev/38b4039f740e

My mozconfig is attached in case that helps
This is probably bug 717540.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717540

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.