Delete link from awesome bar and going to another link goes to ghost page

RESOLVED DUPLICATE of bug 669129

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 669129
6 years ago
6 years ago

People

(Reporter: Silvana Salvati, Unassigned)

Tracking

10 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

1) Type in something into the awesome bar.
2) Wait for previously visited links to be suggested under the awesome bar.
3) Hit down on your keyboard to highlight the first suggestion.
4) Hit delete on the keyboard to remove the first suggestion.
5) The 2nd item is automatically highlighted (which is now the 1st item visually).
6) Hit enter.


Actual results:

The browser goes to the first link that was already deleted. I believe the delete did not update the data structure for the awesome bar's suggestion list. It merely made a visual update.


Expected results:

The browser should have gone to the link that was highlighted - the 2nd link which became the 1st link after deleting the 1st link.

Updated

6 years ago
Component: Untriaged → Location Bar
QA Contact: untriaged → location.bar

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669129
You need to log in before you can comment on or make changes to this bug.