Closed Bug 726501 Opened 8 years ago Closed 8 years ago

Panel scrolling broken on Mac

Categories

(Add-on SDK Graveyard :: General, defect)

x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 697215

People

(Reporter: pmarchwiak, Unassigned)

Details

I am the developer of a Firefox Add-on that uses a panel as the primary user interface element (https://addons.mozilla.org/en-US/firefox/addon/password-analyzer/). The panel content can extend past the bottom of the panel. When this happens, scrollbars become visible and one should be able to scroll down to be able to see the rest of the content.
What occurs instead is the content of the panel stays in place when scrolling. Highlighting the text in the panel forces it to refresh partially but the content is still illegible. This behavior was observed on Mac OS X 10.6.8 using Firefox 10.0.1. Scrolling works as expected on both Linux and Windows.
Thanks for reporting this. It turns out it is a known issue ( see the original bug 697215 ) in Firefox, and is currently broken in FF 10, but fixed in FF 11. We tried to get a fix in for 10, but it causes tens of thousands of crashes for Windows users, so it was backed out.

Once Firefox 11 is released, this will no longer be an issue for your add-on. In the meantime, one possible solution for a user is to use Firefox 11 Beta instead.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697215
You need to log in before you can comment on or make changes to this bug.