Cannot login on litmus.mozilla.org

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: camelia.urian, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
Steps to reproduce:
1. Go to https://litmus.mozilla.org
2. Select  "log in"
3. Enter correct username and password.
4. Click on the "Login" button.

Expected results:
 - User is successfully logged in.

Actual results:
 - User is not logged in. Error message displayed on screen:

"Error - Litmus has suffered a serious fatal internal error - Litmus::DB::User can't 
	SELECT user_id, bugzilla_uid, email, password, realname, irc_nickname, enabled, authtoken, last_updated, creation_date FROM users
	WHERE
	  lower(email) = lower(?)
: Can't use an undefined value as an ARRAY reference at /usr/lib/perl5/site_perl/5.8.8/Class/DBI.pm line 1140."
(Reporter)

Updated

7 years ago
Severity: normal → critical
ups confirmed, adding coop to this bug, maybe he has a idea

Updated

7 years ago
Severity: critical → blocker
(In reply to Carsten Book [:Tomcat] from comment #1)
> ups confirmed, adding coop to this bug, maybe he has a idea

to summarize from irc:

1) coop is out today, but camd took litmus over from coop ~apr2011. cc-ing camd.

2) camd doesnt appear to have access needed to fix this db issue himself. camd, if this is accurate, can you file bug with IT to get yourself access, or file bug with IT to have them restart the DB if that is in fact the root cause?

Comment 3

7 years ago
I don't have access to the box either, but it appears the db server is running: you should get a different error message and wouldn't see the homepage if the db were inaccessible. Though it likely can't hurt to reboot the db server and Apache for good measure. The Apache error log on the box might well have a more detailed error message too.

I don't suppose someone recently updated any of the perl modules on the server? 

I'd be happy to take a further quick look at this if necessary.

Comment 4

7 years ago
> 2) camd doesnt appear to have access needed to fix this db issue himself.
> camd, if this is accurate, can you file bug with IT to get yourself access,
> or file bug with IT to have them restart the DB if that is in fact the root
> cause?

What is the "db issue" ?
I tried restarting Apache, to no avail.  This looks like a perl error to me, rather than a DB problem.  I think :zach's guess is reasonable, but these hosts are devoted to litmus, so they wouldn't have seen an update by anyone else.

I think we'll need to wait until a litmus dev is available.

Comment 7

7 years ago
If someone resets my ldap password and/or public key, I can take a brief look this afternoon. Otherwise, perhaps coop can take a look when he's back.

You can also produce similar errors by going to the statistics page or any kind of search. It seems to happen on anything that touches the users table.
Looks like Matt Zeier had some of his guys, in his words "poke around" and fixed it.  I didn't get details of what they did.  But it seems to be working now.

I'll get trained on what I need to do in the future to fix issues like this.
All I did was restart Apache (and run 'hg diff' in /opt/webtools/litmus-hg, and cry 11392 tears at the size of the diff).  I see coop logged in, so I expect he fixed it.  At any rate, this is done.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(In reply to Cameron Dawson [:camd] from comment #8)
> Looks like Matt Zeier had some of his guys, in his words "poke around" and
> fixed it.  I didn't get details of what they did.  But it seems to be
> working now.
> 
> I'll get trained on what I need to do in the future to fix issues like this.

(In reply to Dustin J. Mitchell [:dustin] from comment #9)
> All I did was restart Apache (and run 'hg diff' in /opt/webtools/litmus-hg,
> and cry 11392 tears at the size of the diff).  I see coop logged in, so I
> expect he fixed it.  At any rate, this is done.

per irc w/coop: coop didnt actually change anything here, litmus was already working when he logged in. Dustin/mrz: looks like something you did fixed it, which is cool. For camd's future reference, did you do anything else apart from restarting Apache?
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
i guess john didn't meant to reset this bug :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Verified FIXED; I just logged in successfully:

[13:38:46.224] POST https://litmus.mozilla.org/index.cgi [HTTP/1.1 200 OK 381ms]
[13:38:46.633] GET https://litmus.mozilla.org/js/Litmus.js [HTTP/1.1 304 Not Modified 303ms]
[13:38:46.636] GET https://litmus.mozilla.org/js/RunTests.js [HTTP/1.1 304 Not Modified 313ms]
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: x86 → All
(In reply to Carsten Book [:Tomcat] from comment #11)
> i guess john didn't meant to reset this bug :)
Actually, it was intentional, as I wanted info on what dustin/mrz did to fix this, for future reference. I should have downgraded from blocker, though, sorry.


(In reply to John O'Duinn [:joduinn] from comment #10)
> (In reply to Cameron Dawson [:camd] from comment #8)
> > Looks like Matt Zeier had some of his guys, in his words "poke around" and
> > fixed it.  I didn't get details of what they did.  But it seems to be
> > working now.
> > 
> > I'll get trained on what I need to do in the future to fix issues like this.
> 
> (In reply to Dustin J. Mitchell [:dustin] from comment #9)
> > All I did was restart Apache (and run 'hg diff' in /opt/webtools/litmus-hg,
> > and cry 11392 tears at the size of the diff).  I see coop logged in, so I
> > expect he fixed it.  At any rate, this is done.
> 
> per irc w/coop: coop didnt actually change anything here, litmus was already
> working when he logged in. Dustin/mrz: looks like something you did fixed
> it, which is cool. For camd's future reference, did you do anything else
> apart from restarting Apache?

Dustin/mrz ?
(Assignee)

Updated

2 years ago
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.