Render problem in 32-bit mode.

UNCONFIRMED
Unassigned

Status

()

Core
Graphics
UNCONFIRMED
6 years ago
6 years ago

People

(Reporter: Deng Xiyue, Unassigned)

Tracking

10 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

Visiting http://classic.battle.net/diablo2exp/.


Actual results:

This results in a garbled page: that is when scrolling everything is mixed like not refreshing. It happens under Mac OS X (10.6 in my case) but not under Linux (Ubuntu 11.10 in my case).


Expected results:

Should be a correctly rendered page.
Can you try the Firefox safemode http://support.mozilla.com/en-US/kb/Safe+Mode.
That disables addons but also the graphic hardware acceleration.
(Reporter)

Comment 2

6 years ago
(In reply to Matthias Versen (Matti) from comment #1)
> Can you try the Firefox safemode
> http://support.mozilla.com/en-US/kb/Safe+Mode.
> That disables addons but also the graphic hardware acceleration.

I tried safe mode with addons disabled, but the page is still garbled the same way.
(Reporter)

Comment 3

6 years ago
It seems that a new profile doesn't suffer from the problem. After some digging, it turns out that it is caused by some custom print setting that whatever set it. So I'm marking it as resolved/invalid. Sorry for the confusion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

6 years ago
(In reply to Deng Xiyue from comment #3)
> It seems that a new profile doesn't suffer from the problem. After some
> digging, it turns out that it is caused by some custom print setting that
> whatever set it. So I'm marking it as resolved/invalid. Sorry for the
> confusion.

And it seems not that easy. It turns out that only when launching Firefox by opening profile manager (as in `firefox -profilemanager`) that this problem disappears. When opening normally by clicking the icon, no matter whether it is in safe mode or new profile the page is garbled. I have no idea why but hope this information is helpful for the developers.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 5

6 years ago
Also to be more clear, print settings are irrelevant in this issue (I got confused by tweaking the print settings when starting by 'firefox -profilemanager'). Only the way to start firefox matters ('firefox -profilemanager' is fine, while normal start is affected), not the custom config settings, nor profile in use.
Created attachment 598810 [details]
Screenshot after load

Certain parts of the page are never drawn, and thus display parts of previous tab
Created attachment 598812 [details]
Screenshot after scroll

After scroll, those parts are still not (re)drawn, leaving the page garbled
The problem occurs on both Stable (10.0.2) and Nightly, but only when layers.acceleration.disabled is set to true. Toggling this back to false and restarting solves the issue for me.
This is the graphics section of about:support (when the pref is set to true).

Graphics
  Vendor ID                       10de
  Device ID                       0863
  WebGL Renderer                  NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine -- 2.1 NVIDIA-1.6.36
  GPU Accelerated Windows         0/1

Updated

6 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
QA Contact: untriaged → thebes

Comment 10

6 years ago
Same thing happening here, on 11.0 on OSX 10.7.2 when pref is set to true

Vendor
  ID0x1002
Device
  ID0x6741
WebGL                   
  Renderer ATI Technologies Inc. -- ATI Radeon HD 6630M OpenGL Engine -- 2.1 ATI-7.12.9
GPU Accelerated Windows 0
(Reporter)

Comment 11

6 years ago
I checked the settings, and my "layers.acceleration.disabled" is "false" by default. Only when I manually set "layers.acceleration.force-enable" to "true" does the page displays correctly. When starting from "firefox -profilemanager" I don't have to touch those settings.

about:support with "layers.acceleration.force-enable" set to "false":

Vendor ID
  10de
Device ID
  0863
WebGL Renderer
  NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine -- 2.1 NVIDIA-1.6.36
GPU Accelerated Windows
  0/1

about:support with "layers.acceleration.force-enable" set to "true":

Vendor ID
  10de
Device ID
  0863
WebGL Renderer
  NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine -- 2.1 NVIDIA-1.6.36
GPU Accelerated Windows
  1/1 OpenGL


Also, not necessarily the same bug, but I found some other sites that behave strangely become normal when also starting firefox with "-profilemanager": The page has some javascript callbacks like autoloading page content (when you scroll down to some point it loads more contents) and some other events, and they are not working when starts normally but do work when starting with "firefox -profilemanager". I guess the inconsistency between these 2 modes could be the culprit.
(Reporter)

Comment 12

6 years ago
I might have found the problem. It is when Firefox is running in 32-bit mode that causes the problems. When switched back to 64-bit mode it works fine. I marked Firefox to run in 32-bit mode a long time ago to use the quicktime plugin and just remembered it and switched back. However, it is still a problem for 32-bit mode to behave differently.
(Reporter)

Updated

6 years ago
Summary: Fail to render Diablo II portal page. → Render problem in 32-bit mode.
You need to log in before you can comment on or make changes to this bug.