Status

()

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: fade_yu, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

Tools->clear recent history -> clear everything, EXCEPT cookies and active logins.



Actual results:

I've closed Firefox, BUT, when i tried to reopen it - i got error message: 'firefox is still running, etc, etc'. I had to delete it from 'process list' in windows task manager.

This happens in few last version of firefox (from 8.0, i think), and not just on my pc (i tried one more)



Expected results:

I guess that error message shouldn't appear, and that FF should be reopened right after i clear history and close it. :)

Comment 1

7 years ago
How long did you wait for the clear history to finish?
(Reporter)

Comment 2

7 years ago
I always wait till the clearing end. And then i close browser, and i have to wait (20-30 seconds) to reopen it.

Comment 3

7 years ago
It is normal to have to wait until you can re-open Firefox. (there are open bugs on trying to decrease this time)

If you don't do the clear history function first, how long do you have to wait between closing Firefox and re-opening.
(Reporter)

Comment 4

7 years ago
Ah, so, thanks... but interesting thing is that i noticed this just in newer versions of browser. 

If i don't do clear history, then there is no ... ups... LOL, now i tried this (closing and instant re-opening) and i got same error message... :D

and this is first time i experienced it. :)

Maybe it is related to add-ons (currently there are : firebug, tamper data, password exporter, header spy)???

Comment 5

7 years ago
Extensions definitely can increase the amount of time required to shutdown...

You can see how long the difference is by running in safe mode and seeing how quickly you can re-open

I think the right resolution here is a WORKSFORME or dup it to an existing bug (like maybe Bug 286355 (give better option in dialog) or Bug 403623 (a similar issue))
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.