Multiple issues with UTF characters rendering with FF 9 and FF 10

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: gvikutan, Unassigned)

Tracking

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

Some special UTF8 characters are not rendered in Firefox 9 and Firefox 10.

To reproduce, go to this test page using FF9 or FF10: http://www.fileformat.info/info/unicode/char/2643/browsertest.htm

In FF9 only a small subset of U+26xx characters is not rendering, in FF10, almost none of them can be shown (check all U+264[x] characters, on FF10, only 2 or 3 of them are rendered correctly.
This is a regression, it's working fine on the same machine with FF 2 and 3 browsers.

Windows XP / Firefox 9 and Firefox 10.




Actual results:

Special UTF8 characters are not rendered at all, blank spaces are shown instead.


Expected results:

The UTF characters should be shown correctly. This works fine on Chrome 10-16, on IE 7, 8 and on Firefox 3.
(Reporter)

Updated

6 years ago
The issue may be due to bad fonts installed on your system. You can use the fontinfo add-on to determine what font Firefox is trying to use to display the problem characters - this will be helpful for diagnosing the problem.
(Reporter)

Comment 2

6 years ago
List of fonts used:
Microsoft Sans Serif
Miriam Fixed
Trebuchet MS Bold
Verdana

I doubt this is the font issue since the same characters are shown correctly on the same system but with Firefox 3. I have multiple firefox versions installed and switching between them using profile.
Also, I've seen this issue on a brand new Lenovo laptop with Firefox 10.
(Reporter)

Comment 3

6 years ago
I do have Microsoft San Serif installed on my machine and it supports these characters.
It's possible that different versions of Firefox are picking different "fallback" fonts when the page contains characters that are not supported in the font family (or families) specified in CSS or in the browser preferences.

Please select _one_ of the "problem" characters (i.e. use the cursor to highlight the blank space where the character should be) and then use the Show Fonts in Selection command from the right-click popup menu (when the fontinfo is installed) to check which font is selected for that specific character, and let us know (a) the character number involved, and (b) the font that Firefox tells you it's using.

You could try this for several of the "missing" characters, to see if the same font is involved in each case.

The same investigation on the brand new Lenovo laptop where you've seen the issue would also be helpful - thanks!
(Reporter)

Comment 5

6 years ago
I used this character: U+2643 and the following test page:
http://www.fileformat.info/info/unicode/char/2643/browsertest.htm

The font FF is using for the character is "Miriam Fixed" for all 3 options: UTF-8, Hex escape, and Decimal escape.
Browser character encoding is set to UTF8.
FF version: 9.0.1 (WinXP).

thanks.
Hi gvikutan, I'm sorry this bug report was overlooked for so long. I just came across it, and the character and test page you link to appear to work now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.