Firefox 10 doesnt load flashplayer video (audio works) on many sites

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Bellaneph, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 596730 [details]
firefox errors3.jpg

User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.26) Gecko/20120128 Firefox/3.6.26
Build ID: 20120128224517

Steps to reproduce:

I didn't do anything to cause this problem.  Just one day - about a week ago - many sites wouldn't play flash player videos.  The audio would work and you could tell the player was there, but you couldn't see anything except a black box (in some cases a white box).
To troubleshoot, I: 
1) uninstalled Firefox 10 and reinstalled 2) installed Firefox 9 3) installed Firefox 11 beta 4) uninstalled Flashplayer and reinstalled 5) uninstalled Flashplayer using Flash Player uninstall tool 6) Installed Flashplayer beta 7) updated Java 8) unchecked advance acceleration in flash player 9) unchecked advanced acceleration in Firefox 10) deleted my Firefox profile in Windows 7 then remade it after installing a new and clean copy of Firefox 10 and flash player 11) Loaded Firefox with add ons disabled 12) Created a new profile using Mozilla's guide to creating a new Profile and used test profile to restart Firefox 13) tried uninstalling flash then relogging then installing flash and relogging 14) tried to find suggestions online for the errors I screen-captured on a site where the problem happened.  

None of these things did anything to help the problem I was having.  I checked Chrome and IE to make sure the problem was isolated to Firefox and it was, the video plays flawlessly in Chrome and IE.  Finally, today, I resorted back to version 3.6.26 and it now works.  The problem lies within how firefox interacts with flash player on these sites on the updated versions.  Please keep up support on 3.6.26 because it's the only version of Firefox I can use at the moment or help me fix this bug.  Thanks


Actual results:

Many sites that utilize flash player wouldn't display the video portion of the video (i,e, ancestry.com advance viewing mode, cbs online tv shows, docs.com pdf files).  When the file contained audio, I could hear what was going on, but the video was replaced by a black box or a white box in some cases.  When you right click on settings, you couldn't see the pop up flash player settings box.


Expected results:

It should have played the video as well as the audio.  You should have been able to see the image.

Comment 1

7 years ago
Bugzilla is not for end-user support. Your best bet to get assistance is by visiting the Firefox help site -> https://support.mozilla.com/en-US/kb/ask

Note: Chrome and IE do NOT use the same Flash player as Firefox so the fact that they work has no bearing on Firefox.
I think it's ok given what the reporter already tried but there is not much we could do. QA, our developers and million of users can't reproduce it and this is also basically a third party software that doesn't work.

Comparing us with IE in case of plugin problems is bad (activeX vs npapi) and with Chrome it's also bad because they use their own modified flash plugin.

try switching dom.ipc.plugins.enabled in about:config to false.

Comment 3

7 years ago
Reporter -> Are you still seeing this with Firefox 11 and the latest Flash player?
Hello,

can you please check this on new Version 31 of Firefox?
and confirm if still exists, or we can close it.

[bugday-20140818]
Flags: needinfo?(Bellaneph)
Component: Untriaged → Flash (Adobe)
Product: Firefox → Plugins
Version: 10 Branch → 10.0
old bug and no response from comment#3 + comment#4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(Bellaneph)

Comment 6

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.0 → unspecified
You need to log in before you can comment on or make changes to this bug.