about:memory?verbose leaks when holding Cmd/Ctrl+R for a while

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

6 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

7 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a2) Gecko/20120209 Firefox/12.0a2 ID:20120209042012

When about:memory?verbose is open and you keep holding Cmd/Ctrl+R down for some seconds you will notice a lot of inner-windows which are zombies from the former about:memory?verbose inner-window:

│         ├─────29,937 B (00.03%) -- top=7 (inner=208)
│         │     ├──25,065 B (00.03%) -- inner-window(id=208, uri=about:memory?verbose)
│         │     │  ├──17,560 B (00.02%) ── style-sheets
│         │     │  └───7,505 B (00.01%) ── dom
│         │     ├─────696 B (00.00%) -- inner-window(id=201, uri=[system])
│         │     │     └──696 B (00.00%) ── dom
│         │     ├─────696 B (00.00%) -- inner-window(id=205, uri=[system])
│         │     │     └──696 B (00.00%) ── dom
│         │     ├─────696 B (00.00%) -- inner-window(id=203, uri=[system])
│         │     │     └──696 B (00.00%) ── dom
│         │     ├─────696 B (00.00%) -- inner-window(id=206, uri=[system])
│         │     │     └──696 B (00.00%) ── dom
│         │     ├─────696 B (00.00%) -- inner-window(id=202, uri=[system])
│         │     │     └──696 B (00.00%) ── dom
│         │     ├─────696 B (00.00%) -- inner-window(id=207, uri=[system])
│         │     │     └──696 B (00.00%) ── dom
│         │     └─────696 B (00.00%) -- inner-window(id=204, uri=[system])
│         │           └──696 B (00.00%) ── dom
│

Waiting a while until a GC/CC happened or running minimize memory will remove those entries.
Whiteboard: [MemShrink]
I think this is not a bug.  It's just how windows work in Gecko.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.