Google maps RMB menus no longer selectable with FF10

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: dave, Unassigned)

Tracking

10 Branch
Other
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (OS/2; Warp 4.5; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120130135311

Steps to reproduce:

Right Mouse button on a Google map brings up FF RMB menu with the Google map RMB menu behind it. 


Actual results:

Hit escape to get to the Google menu - Could not select on Google menu


Expected results:

It used to be that hitting escape would allow a selection on the Google menu
What is your setting of preferences/content/javascript/advanced/disable or replace context menus ?

Comment 2

7 years ago
Not sure what the correct component is, but I see this on SeaMonkey also.  I believe it is an OS/2 specific mouse handling issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

7 years ago
(In reply to Dave Saville from comment #0)
> Expected results:
> It used to be that hitting escape would allow a selection on the Google menu

Expected results:
Browser menu should not be shown, only the Google menu.
(Reporter)

Comment 4

7 years ago
Nothing checked in javascript/advanced/

As far as I can recollect FF has always shown the FF menu overlaid on the Google menu. But as I said escape would let you then access the underlying one.

Comment 5

7 years ago
I only get the Google menu when right clicking. FF 10.01 with a fairly new profile. Also the same with SM 2.7.1
Dave perhaps you should try a different/new profile.
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 6

7 years ago
Didn't mean to change the status to unconfirmed but until Dave tests with a new profile I'll leave it as is.
>Nothing checked in javascript/advanced/
The default is that "[x] Move or resize... and [x] Disable or replace the context menu are both checked.
In that case you would only get the context menu from the page.
I'm not sure that we can guarantee that you are still be able to access the sites context menu if you override it with that option.

Comment 8

7 years ago
Yes, WFM with "Disable or replace context menus" selected.  I should have checked that; I just assumed the Google one wouldn't be shown at all.
(Reporter)

Comment 9

7 years ago
Yes, checking that option works for me. Shame it is a global setting.

Comment 10

6 years ago
Working as designed?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.