messages are getting lost for my default IMAP account

RESOLVED FIXED

Status

MailNews Core
Backend
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: Navin Gupta, Assigned: Bienvenu)

Tracking

({dataloss})

Trunk
x86
Windows NT
dataloss

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The inbox count shows that 1 new unread message has arrived but I cannot see
the message. 

Opened 4x and saw the message. The unique thing about the message was the date 
12/31/69.
(Reporter)

Comment 1

17 years ago
Adding keyword dataloss
Keywords: dataloss
(Reporter)

Comment 2

17 years ago
When I delete my inbox.msf. I can see the message but the date in the 
header is 2/6/40. Viewing the source shows the date of the message as
Fri, 01 Jan 1904 03:23:57 -0700

Updated

17 years ago
QA Contact: esther → huang
(Assignee)

Comment 3

17 years ago
If you view messages | unread only, does the message show up?
Assignee: mscott → bienvenu
(Reporter)

Comment 4

17 years ago
I have backed up inbox.msf. Do you want me to try it out ?
(Assignee)

Comment 5

17 years ago
yes, if you could, it would be nice to know that we just have one problem
instead of multiple ones.
(Reporter)

Comment 6

17 years ago
I am pretty sure that the message was lost. Both mscott and I sorted the
thread pane by date and could not find the message.  We also sorted by the 
sender and could not find the message. 

(Assignee)

Comment 7

17 years ago
If you view messages | unread only, does the message show up?
(Reporter)

Comment 8

17 years ago
I tried to use the backup inbox.msf, but it will not help because I read the 
message in 4.7. 
(Assignee)

Comment 9

17 years ago
how about marking it unread with 4.7, then restoring your backup .msf file?
(Reporter)

Comment 10

17 years ago
Sorry, that message seems to have been deleted, by mistake. 
(Assignee)

Comment 11

17 years ago
d'oh, well, if it happens again, try just view messages unread only.
(Assignee)

Comment 12

17 years ago
Created attachment 28878 [details] [diff] [review]
proposed fix
(Assignee)

Comment 13

17 years ago
Here's the fix - we were missing every 200th thread (actually, 201, 401, etc)
when building up the view. The attached patch fixes that. Can I get an r= and
sr= from Seth and Navin? thanks!

Comment 14

17 years ago
doh! sr=mscott
(Assignee)

Comment 15

17 years ago
fix checked in. Verification will be hard since I had the only reproducible
case. But,basically, if you have 201 unique threads in a folder, the 201th one
would not get displayed. With this fix, it will get displayed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.