With the removal of application.ini, there is no way to turn off profile migration

VERIFIED INVALID

Status

()

defect
VERIFIED INVALID
7 years ago
6 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

(Blocks 1 bug, {regression})

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
bug 286557 added an entry to application.ini, EnableProfileMigration, which allowed profile migration to be turned off.

It could not be done via a preference because of how early the code runs (see https://bugzilla.mozilla.org/show_bug.cgi?id=286557#c12)

Unfortunately bug 686466 removed the application.ini completely (or at least hardcoded it so that it can't be changed to set this options)

So we need a way to turn off profile migration again.
Reporter

Updated

7 years ago
Blocks: 686466
Reporter

Updated

7 years ago

Updated

7 years ago
Keywords: regression
Thanks for the tip. You write in bug 727122:

> You may need to add an argument -override <path/to/override file> to get it to work.

Mike can correct me, but I think that won't work in a corporate desktop environment where you can't always control how Firefox is started.
(just how it's installed)
(In reply to Ben Bucksch (:BenB) from comment #2)
> Thanks for the tip. You write in bug 727122:
> 
> > You may need to add an argument -override <path/to/override file> to get it to work.
> 
> Mike can correct me, but I think that won't work in a corporate desktop
> environment where you can't always control how Firefox is started.

That trick isn't needed for the EnableProfileMigrator in override.ini - if you read the code, you'll see that if the migrator is going to run, override.ini is attempted to be loaded regardless of any arguments.
Reporter

Comment 5

7 years ago
So yeah, I just learned this today.

So for profile migrator, override.ini is read without passing an argument.

And it looks like for crash reporter, there is a file crashreporter-override.ini.

The only thing that can be specified in the default override.ini is the EnableProfileMigration stuff. Nothing else is read.

I have no idea on crashreporter-override.

I had no idea this feature was there, and it's documented as well:

https://developer.mozilla.org/en/Command_Line_Options

Learn something new every day.

So this bug is invalid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Thanks, Mark!
Status: RESOLVED → VERIFIED

Comment 7

6 years ago
Hello guys,

There is a problem with application.ini since Firefox/Thunderbird 11 and SeaMonkey 2.8.

Can you read : https://bugzilla.mozilla.org/show_bug.cgi?id=723493 and resolve this bug?

I would like to use new versions.
You need to log in before you can comment on or make changes to this bug.