win: sometimes takes several clicks to follow a link

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: jmichae3, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

click a random link on a page.  sometimes the page just sits there and I have to click again.  frustrates me.  none of my other windows applications do that, but browser applications do that. is the packet getting lost?  watch for this, you will notice it too.


Actual results:

every once in a while, firefox will refuse to respond to a mouse click.


Expected results:

page should have loaded.

Comment 1

7 years ago
Getting a loadering throbber?
#WORKSFORME

Tested on XP and 7 with FF 30 and 31.
should be closed
(In reply to Stefan Weiss [:sir_none] from comment #2)
> #WORKSFORME
> 
> Tested on XP and 7 with FF 30 and 31.
> should be closed

Let's ask one more time, just to be sure. I'll place a [closeme] tag in the QA whiteboard for three weeks from now, in case the reporter won't answer we will close it.

Jim: could you please try if the problem is still present with a recent version of Firefox? For instance, you can try with 31 (you can download it here → https://www.mozilla.org/en-US/firefox/all/)

Thanks!
Francesca
QA Whiteboard: [closeme 2014-08-29]
Flags: needinfo?(jmichae3)
(Reporter)

Comment 4

4 years ago
right now my firefox (31 windows I think) is locked up continually bringing up Unresponsive Script errors and my machine is thrashing and I can't move the mouse for sometimes 10-30 minutes.
I think I am trying to do too much on that dual-core with 2GB RAM.
my main computer just got a virus and I am trying to recover it.
having problems...
Flags: needinfo?(jmichae3)
Hello Jim,

thanks for your feedback :-)
sorry to hear about your problems, but the error you reported in 2012 is no more there?
if yes, please give us some more details on the problem.
Flags: needinfo?(jmichae3)
(Reporter)

Comment 6

4 years ago
what I have discovered may be a bug in some browser driver thingy in windows? cant remember for sure, either it was any browser I use, it ir was just ff (memory is fuzzy now since I can't test), I have this problem where mouse clicks sometimes get dropped. it could b that the mouse driver is not reacting fast enough, but on an i7-3970x with 64GiB that driver must be really heavy to be a problem. interrupt handlers are typically done with high speed, and a mouse is a serial port device. it's possible some bytes are getting dropped in the tranmsmission or reception by the driver. I don't seem to see this problem in other programs.

my guess is ff or WOW64 32-bit emulation is just slow enough on my 64-bit box that whatever event handler for mouse events is not getting its events in time?
I don't know the insides of ff. but I see some gradual slight slowing in ff when it gets a lot of tabs.

is ff emptying the windows message queue while blocking/processing as an intended feature to prevent messes/oopses from queued-up mouse/kb events would it not? or...? wondering if my bug is invalid.

from what I have seen it does seem to work pretty good.
Flags: needinfo?(jmichae3)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.