System tray notification reports new drafts as new incoming mail

RESOLVED DUPLICATE of bug 687140

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 687140
6 years ago
5 years ago

People

(Reporter: R. Schreurs, Unassigned)

Tracking

9 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I was busy composing a new message.

Thunderbird received new incoming mail. This invoked a system tray notification, including an envelope icon and a sliding panel, showing a list of abstracts from messages. This list included the message is had been composing, which, of course, was not incoming mail.

Only incoming mail should be reported in the system tray notification panel. If concepts are shown, your first thought is that you inadvertently sent the incomplete mail to some recipients and that there is a reply to it.

Thunderbird automatically saves concepts during the composition of messages. These concepts are listed a new, i.e. in bold, until they have been clicked in the list of messages. It appears that these new messages are included in the notification panel, although they do no invoke its appearance.

By the way, Thunderbird is connected to a Dovecot IMAP server on a NAS.

Comment 1

6 years ago
(In reply to R. Schreurs from comment #0)
What is the version you are using? I tried what you described here but I couldn't reproduce it. The tool-tip shows only unread messages, it doesn't show message being typed.
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.1) Gecko/20120208 Thunderbird/10.0.1
Application Build ID: 20120208125353
(Reporter)

Comment 2

6 years ago
I have been able to reproduce this issue with version 9.0.1 and 10.0.2.

Some additional information:
* Make sure the message in concept is for the same e-mail account as the mail received;
* I use View - Folders - Unified;
* Wait for the message to be automatically saved in concept, or manually save it;
* Verify the Concept folder is displayed in bold and with the number of "unread" concept in brackets behind it.

See the attachment for a screen shot of the inbox and the pop-up.
(Reporter)

Comment 3

6 years ago
Created attachment 598374 [details]
Screenshot illustrating the issue

Comment 4

6 years ago
(In reply to R. Schreurs from comment #2)
Confirmed after you provided more info. By "Concept" you mean "Draft". This bug was reported earlier: bug 676249.

My Thunderbird application info:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.1) Gecko/20120208 Thunderbird/10.0.1
Application Build ID: 20120208125353
(Reporter)

Comment 5

6 years ago
(In reply to Hashem Masoud from comment #4)
I use the Dutch language and didn't use the correct translation...
Didn't find the earlier reported bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 676249
(Reporter)

Updated

6 years ago
Summary: System tray notification reports new concepts as new incoming mail → System tray notification reports new drafts as new incoming mail
Bug 676249 refers to problem of both bug 676249 and bug 687140.
Duping to bug 687140 which is obviously for "wrong new mail alert on newly saved draft mail", for ease of tracking.
Duplicate of bug: 687140
You need to log in before you can comment on or make changes to this bug.