Closed Bug 727426 Opened 10 years ago Closed 9 years ago

GLXtest process failed - crashing when Firefox starts with Test Pilot and (Multiple Tab Handler or Diigo Toolbar)

Categories

(Core :: JavaScript Engine, defect)

10 Branch
x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: h, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120209214325

Steps to reproduce:

Firefox crashes nearly every time I start it or very soon after.  It has happened on a variety of web pages immediately after loading or while loading.  I am typing this while Firefox is in safe mode.  It is the first time I have tried safe mode


Actual results:

  I am typing this while Firefox is in safe mode.  It is the first time I have tried safe mode and, it appears to be more stable.  It may be similar to bug 681114 except that user only experienced it after nightly back up.  I send a few crash reports before Firefox starts and stays open for long enough to read a three sentences on a web page.  The problem started last week.  It was not after an update or the installation of new software, no new addons for Firefox.  I tried running Ubuntu Update Manager but my system was up to date.  

I am happy to try to answer questions.
Please post a link to your crash report from about:crashes.

Could you provide the list of add-ons you have installed? you can copy the list easier from about:support.
Severity: normal → critical
Keywords: crash
Virgil, thank you for taking an interest.  I have attached the Troubleshooting Information in a file created in Libre Office Calc.  You have more than you asked for - just in case it's helpful.

I have tried a few things since posting the bug and two of them might be worth mentioning.    I went into Preferences and turned off hardware acceleration but Firefox crashed when it re-started.   I have disabled the two Zotero addons and opened Firefox three times.  Each time, it has been stable.  It surprised me because fancy graphics and system checking are not what Zotero is about.  I'll open Firefox a few times tomorrow and add another post here to say whether or not it continues to be stable.
(In reply to Catbells from comment #3)
> I have attached the Troubleshooting Information in a file created in Libre Office
> Calc.
Can you change the attachment type in order to be able to open it with LibreOffice?

Can you provide a stacktrace (see https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report)?
Summary: GLXtest process failed - crashing when Firefox starts → GLXtest process failed - crashing when Firefox starts with Zotero add-ons
Attached file Crashing Thread
Firefox crashed again.  I hadn't made any changes.  The attachment is the crashing thread from the crash report.  It was created in LibreOffice Calc
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Crash Signature: [@ GCGraphBuilder::NoteXPCOMChild]
Component: Untriaged → JavaScript Engine
Ever confirmed: true
Product: Firefox → Core
QA Contact: untriaged → general
Scoobidiver, Thank you for your help.  I'm afraid I don't understand "Can you change the attachment type in order to be able to open it with LibreOffice?"  It's a LibreOffice Calc spreadsheet already but, I can make it csv or I can try to make it a LibreOffice Writer document, if you prefer one of those.
Attached file about:crashes
Scoobidiver, I think you were asking for the Report ID numbers from about:crashes.  There are several and I have listed them in a text file.  It has two columns separated by a tab (sometimes two to make it line up in my gedit).
Summary: GLXtest process failed - crashing when Firefox starts with Zotero add-ons → GLXtest process failed - crashing when Firefox starts
Scoobidiver, Thank you for being so quick to amend the title of this bug.  After my post suggesting it might be Zotero, Firefox crashed while Zotero was disabled.  As it doesn't seem to be Zotero, I've deleted "with Zotero add-ons" from the title.  Hope you don't mind.
Does it happen in Safe Mode?
Which extensions make it crash?
I've tried Firefox a couple of times in Safe Mode and it seems to be alright.  I'll turn my extensions on one at a time. It may take a few days as I need to try each one two or three times and, can't work on it full time.
It's when I have Mozilla Test Pilot and Multiple Tab Handler enabled.  It's also when I have Mozilla Test Pilot and Diigo Toolbar enabled.  When Multiple Tab Handler and Diigo Toolbar are enabled with Test Pilot disabled, there are no crashes.
Summary: GLXtest process failed - crashing when Firefox starts → GLXtest process failed - crashing when Firefox starts with Test Pilot and (Multiple Tab Handler or Diigo Toolbar)
Blocks: 469267
It also crashes with a combination of Reminder Fox and Test Pilot and both Multiple Tab Handler and Diigo Toolbar switched off, though it is much less frequent than with Test Pilot and (Multiple Tab Handler or Diigo Toolbar).

Actually, I haven't text combinations of Test Pilot and other addons.  This would be quite time consuming to do and I'll wait until someone is looking at the bug.
Thanks for looking into this, Catbells!

It would be good if somebody else could look at this and see if it reproduces on a clean profile, and if platforms besides Linux are affected.

It sounds like the following combinations are problematic:
Test Pilot + Multiple Tab Handler
Test Pilot + Diigo Toolbar
Test Pilot + Reminder Fox

Looking at any one of these combinations would be great (though it sounds like the first two are more likely to cause the problem).  If I can get a reproducible case, I can start looking into this.
Keywords: qawanted
Hi Andrew, It's great that you're willing to take an interest, thank you.

I don't know if it's of interest but the latest crash report is at https://crash-stats.mozilla.com/report/index/bp-86352dc9-9b86-41e7-9ddd-a1d5a2120306.  Since initially reporting the bug, Firefox 10.2 has installed and the crash report perhaps shows any affect on the bug, probably none.
Test Pilot wouldn't be disabled.  I tried and got more crashes.  I clicked Tools, Add-ons and Test Pilot was showing that it would be disabled after a restart.  So I clicked restart and re-opened the Add-ons tab.  Test Pilot still showed that it would be disabled after a restart.  I clicked the Remove button, restarted, reported the ensuing crash and it had been removed successfully.
Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

I've installed the 4 add-ons (Test Pilot, Multiple Tab Handler, Diigo Toolbar, Reminder Fox) in 10.0.2. But some extra information would be useful in order to attempt to reproduce this issue. 

Catbells, is there any specific action that triggers the crash in your case? As in visiting sites with Flash, restarting, installing an add-on etc.
Do you have any  preferences which you modified and which might trigger this? Do you use app tabs?
Virgil, thank you for your interest and for following this thread.
A couple of days ago I changed my home page but through all the crashes it was http://www.therainforestsite.com/clickToGive/home.faces?siteId=4.  It has happened while looking at other sites as I often look for different information in a large variety of sites.  You're welcome to a copy of my history, but I suspect that if you have time to wade through it, you would rather spend that time in more enjoyable ways.  I also like to watch archives of television programmes and sometimes I play a video in Facebook.  They have all been playing without crashing.  Sorry, I don't know whether they are Flash.  To test my add-ons, I disabled them all and turned them on one-by-one.  One of the first to be enabled was Adblock Plus.  It blocks all adverts including Flash.  I don't think I made an exception for the rainforest site, but their server is down at the moment and I can't check.
I don't know what "app tabs" are.  I generally have two or more tabs open in the browser window (if that helps).
Thank you, Catbells. No luck so far with those add-ons installed and running. Tried modifying some settings, setting some alarms with Reminder Fox. Will announce if anything comes up.

if I'm looking at the crash reports, this seems to be mostly specific for 10.0.2 and not limited to linux.
https://crash-stats.mozilla.com/report/list?signature=GCGraphBuilder%3A%3ANoteXPCOMChild
https://crash-stats.mozilla.com/report/list?signature=ChangeDocumentForDefaultContent
Thank you for trying Virgil and for giving an update.  Don't worry too much about Reminder Fox.  It's a while since I've used it.  There have been no crashes since I removed Test Pilot. The only way to contact the developer seems to be to place a comment in the forum for Test Pilot in Google Groups.  I did that two weeks ago but no-one seems interested.
Depends on: 737690
Crash Signature: [@ GCGraphBuilder::NoteXPCOMChild] → [@ GCGraphBuilder::NoteXPCOMChild] [@ GCGraphBuilder::NoteXPCOMChild | nsVariant::Traverse]
It's been nearly 3 months, any status update here? Does the bug still happen for Firefox 13?
Keywords: qawanted
When I saw your comment, Anthony, I re-installed Test Pilot.  I've opened Firefox a few times since then - no crashes.  It's okay to close this.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.