Facebook mobile page is displayed blank due to a -9999999px value in CSS

RESOLVED DUPLICATE of bug 714709

Status

()

Core
Graphics
--
major
RESOLVED DUPLICATE of bug 714709
6 years ago
5 years ago

People

(Reporter: Camelia Urian, Unassigned)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox11 affected, firefox12 affected, firefox13 affected)

Details

(Whiteboard: [QA^], URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Build: Fennec/13.0a1 2012-02-15
Device: HTC Desire (Android 2.2)

Steps to reproduce:
1. Go to Facebook.com and wait to be redirected to m.facebook.com.
2. Wait for the page to be completely loaded and scroll the page or change the device orientation.

Expected results:
The content is correctly displayed.

Actual results:
The page becomes completely blank. Changing the orientation again repaints the page correctly but when doing a new scroll or orientation change the page becomes blank again.

Notes:
 - The issue is not reproducible on the Android browser.
 - See video at: http://www.youtube.com/watch?v=Bze8nXFVmCY&feature=plcp&context=C361e7a1UDOEgsToPDskJ4vODsGN4DS13W6dxwebXG
Created attachment 597408 [details]
Nightly (02/15)

I was just about to file this too. I see it on the Galaxy Nexus (Android 4.0.2). Attaching a log but I'm not sure if there's anything interesting in it.

Updated

6 years ago
Keywords: regression, regressionwindow-wanted

Updated

6 years ago
tracking-fennec: --- → ?
status-firefox13: --- → affected
I'm also seeing this bug on the Galaxy Nexus (Android 4.0.2), but for me it's much worse.
Basically every page shows up blank for me, except about:home.
Requesting higher priority because it is a top-site issue.
Severity: normal → major
Whiteboard: [QA^]
Created attachment 597840 [details]
testcase

I think I can reproduce it with this testcase.
Steps to reproduce:
- Change orientation to horizontal
- Change orientation to vertical
- Change orientation horizontal

After that, the text on the page has become invisible.
Ok so the issue is the styling 

They are serving Fennec this: i.img u{position:absolute;top:-9999999px}, and Fennec chokes on the negative value.

This is very much similar to bug 714709.

Updated

6 years ago
Summary: Facebook mobile page is displayed blank after scrolling the page or changing device orientation → Facebook mobile page is displayed blank after scrolling the page or changing device orientation due to a -9999999px value in CSS

Updated

6 years ago
Depends on: 714709
Summary: Facebook mobile page is displayed blank after scrolling the page or changing device orientation due to a -9999999px value in CSS → Facebook mobile page is displayed blank after scrolling the page or changing device orientation

Updated

6 years ago
Summary: Facebook mobile page is displayed blank after scrolling the page or changing device orientation → Facebook mobile page is displayed blank after scrolling the page or changing device orientation due to a -9999999px value in CSS

Updated

6 years ago
See Also: → bug 714709
Summary: Facebook mobile page is displayed blank after scrolling the page or changing device orientation due to a -9999999px value in CSS → Facebook mobile page is displayed blank after scrolling the page or changing device orientation
I have no idea why the summary changed a bunch of times, sorry.
Summary: Facebook mobile page is displayed blank after scrolling the page or changing device orientation → Facebook mobile page is displayed blank after scrolling the page or changing device orientation due to a -9999999px value in CSS

Updated

6 years ago
Component: General → Layout
Product: Fennec Native → Core
QA Contact: general → layout

Updated

6 years ago
status-firefox11: --- → affected
status-firefox12: --- → affected

Updated

6 years ago
Summary: Facebook mobile page is displayed blank after scrolling the page or changing device orientation due to a -9999999px value in CSS → Facebook mobile page is displayed blank due to a -9999999px value in CSS
So is this a layout issue, or bad UA sniffing on their end?
This is a Fennec layout issue, see testcase and steps to reproduce in comment 6.
Ah, I see.  That seems highly unlikely to be a layout issue.  Much more likely, we're ending up with a cairo context in an error state or something.
Component: Layout → Graphics
QA Contact: layout → thebes
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 714709
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.