RFE: hide image download placeholders

VERIFIED DUPLICATE of bug 12770

Status

()

Core
Layout
P3
enhancement
VERIFIED DUPLICATE of bug 12770
19 years ago
19 years ago

People

(Reporter: Sam Allen, Assigned: James Everingham)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perf])

(Reporter)

Description

19 years ago
MSIE 5.0 can be configured to not show image placeholders and alt text as
images are downloaded.  For pages that use lots of 1 by x pixel gifs for
spacing, not seeing tons of little boxes cluttering the page looks much
cleaner.  Also, since the vast majority of these images are transparent, not
displaying their placeholders can correctly anticipate the final display of the
page; this gives the appearance of speed.

I suggest that this is made configurable to the user through a preference
option.

Updated

19 years ago
Assignee: rickg → trudelle

Comment 1

19 years ago
This is a feature request you may care about.

Updated

19 years ago
Assignee: trudelle → don

Comment 2

19 years ago
Don, is this yours?
(Reporter)

Comment 3

19 years ago
A new pseudo-class extension in ua.css could solve this problem (more elegantly
than other options, I think).

:-moz-placeholder {visibility: hidden}

Layout will then hide image download placeholders.

The alt text will, of course, also have to be hidden.  So the two rules in
ua.css would be

img:-moz-placeholder {visibility: hidden}
img:-moz-text {visibility: hidden} /* this is for the alt text */

Note that :-moz-text was disabled awhile ago.

Updated

19 years ago
Assignee: don → jevering
Severity: trivial → enhancement

Comment 4

19 years ago
Jim, want to do anything about this one?
(Reporter)

Updated

19 years ago
Summary: RFE: option to hide image download placeholders → RFE: hide image download placeholders
Whiteboard: [perf]
(Reporter)

Comment 5

19 years ago
Has anyone considered implementing this?

With my (limited) knowledge of nglayout, I think that this could be done by
removing nsImageFrame::DisplayAltText and the places where it is called.

Due to the fact that layout now (correctly) expands the alt text of images like
normal text, image download placeholders only appear during loading. So the user
only gets to see them for a few moments, and then they are painted over by the
images themselves. This is, in my opinion, more disorienting than it needs to
be.

Also, the image download placeholders slow NGlayout down on the majority of
pages on the Internet. Time is wasted formatting text (setting font and color),
and drawing the gray inset border. Considering that some pages use a lot of
images, these calculations can add up and detract from the layout engines
performance. (not to mention the perceived performance I've mentioned earlier in
this bug report.)

I've changed my mind and would rather see this at the one and only behavior,
instead of a confusing preference that no one will know how to use.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

19 years ago
*** This bug has been marked as a duplicate of 12770 ***
Status: RESOLVED → VERIFIED
Yup, this is a duplicate. Nice catch.

Once the pseudo-element exists, as requested by bug 12770, new chromes should
be able to implement the hiding of placeholders easily (by tweaking ua.css).

(Note that personally I would rather the alt texts that are in the placeholder
frames be drawn, otherwise on slow connections where the images take a long time
to load, I have to wait for all the images to download before finding out which
one is the link to the ftp site (or whatever I am looking for)).
You need to log in before you can comment on or make changes to this bug.