chrome://browser/content/browser.xul inside Firefox is glitchy

RESOLVED DUPLICATE of bug 298515

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 298515
6 years ago
6 years ago

People

(Reporter: Wolfgang Keller, Unassigned)

Tracking

10 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

1. I typed
chrome://browser/content/browser.xul
into the adress bar of the Firefox browser (let's call it the layer 1 FF).

2. So I get a second browser with its own adress bar (which we'll call layer 2 FF).

3. In layer 2 FF click on the + sign to open a new tab.

4. Switch back to the first tab of the layer 2 FF.

5. Type any web adress (for example www.google.de) into the adress bar of the layer 2 FF and press return key


Actual results:

Nothing happens, but when you either

- switch to the second tab of the layer 2 FF and back to the first one
- minimize the browser windows and maximize it back

the Google page can be seen.


Expected results:

The Google website (or whatever website you typed in) should be shown directly.

Generally the nesting of chrome://browser/content/browser.xul browsers inside each other (especially in combination with opening tabs of browsers inside browsers inside browsers) is rather glitchy. Play around with it (some kind of Firefox inception) and see yourself.

Comment 1

6 years ago
Thanks for your report!

You're right, browser.xul was not designed to be used like that, but there's no reason for us to forbid it from being loaded in a tab, especially since the ability to load other chrome:// URLs in a tab is useful for development. (See also bug 626993).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 298515
You need to log in before you can comment on or make changes to this bug.