Setting browser.cache.offline.enable to false results in an error when opening advanced prefs

RESOLVED DUPLICATE of bug 795764

Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 795764
6 years ago
4 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
We're working on an app where we want to disable the offline cache.

when we did so, we got this error in the console.
 Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://browser/content/preferences/advanced.js :: <TOP_LEVEL> :: line 311"  data: no]
Source File: chrome://global/content/bindings/preferences.xml
Line: 738

You should be able to disable the offline cache without getting an error.
(Reporter)

Comment 1

6 years ago
Sorry. Did not realize cloning a bug grabbed everything.

I just wanted the same product/component.
No longer blocks: 370195, 372969, 372970, 373231, 379590, 398161
No longer depends on: 367447
Summary: Setting browser.cache.offline.enable to false results in a GC error when opening advanced prefs → Setting browser.cache.offline.enable to false results in an error when opening advanced prefs

Comment 2

4 years ago
Duplicate of bug 795764 ?
(Reporter)

Comment 3

4 years ago
(In reply to Tim Nguyen [:ntim] from comment #2)
> Duplicate of bug 795764 ?

Well technically that one is a dupe of this one...
Duplicates work in either direction.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795764
You need to log in before you can comment on or make changes to this bug.