Last Comment Bug 727598 - Create icons for new Next and Previous message buttons created in bug 235666
: Create icons for new Next and Previous message buttons created in bug 235666
Status: RESOLVED FIXED
: polish
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 16.0
Assigned To: Andreas Nilsson (:andreasn)
:
Mentors:
Depends on: 235666 243480
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 13:41 PST by :aceman
Modified: 2012-11-10 12:13 PST (History)
7 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
pinstripe mail-toolbar proposal (15.27 KB, image/png)
2012-05-28 10:00 PDT, Andreas Nilsson (:andreasn)
no flags Details
pinstripe mail-toolbar proposal 2 (14.72 KB, image/png)
2012-05-29 01:37 PDT, Andreas Nilsson (:andreasn)
bwinton: ui‑review+
Details
new icons for all platforms (198.50 KB, patch)
2012-06-05 09:14 PDT, Andreas Nilsson (:andreasn)
no flags Details | Diff | Review
icons+css (215.80 KB, patch)
2012-06-07 09:02 PDT, Andreas Nilsson (:andreasn)
no flags Details | Diff | Review
icons+css v2 (212.84 KB, patch)
2012-06-08 08:40 PDT, Andreas Nilsson (:andreasn)
bwinton: ui‑review-
acelists: feedback+
Details | Diff | Review
icons proposal (16.39 KB, image/png)
2012-06-25 12:25 PDT, :aceman
bwinton: feedback+
bugs: feedback+
Details
new icons based on acemans sketch (201.19 KB, patch)
2012-06-26 08:45 PDT, Andreas Nilsson (:andreasn)
no flags Details | Diff | Review
new icons, new css (215.02 KB, patch)
2012-06-26 10:56 PDT, Andreas Nilsson (:andreasn)
acelists: feedback-
Details | Diff | Review
new icons and css (v3) (216.93 KB, patch)
2012-06-27 04:07 PDT, Andreas Nilsson (:andreasn)
bwinton: review+
bwinton: ui‑review+
acelists: feedback+
Details | Diff | Review

Description :aceman 2012-02-15 13:41:53 PST
This is a followup bug to bug 235666, where new buttons for Next (read) and Previous (read) message buttons were implemented. But they reuse the existing icons used for Next/Previous (Unread) message.

So new icons should be created to differentiate the functions, as the button labels are intentionally identical.

Currently thre next/previous icons contain 2 blue arrows (at least in gnomestripe theme). Maybe the same design with 1 arrow could be drawn.

This bug needs somebody who knows to create those icons and land them into the theme files (mail-toolbar.png and mail-toolbar-small.png).

After that I can make the necessary css updates in the theme to make the buttons use the new icons.
Comment 1 :aceman 2012-02-15 13:51:20 PST
Anybody working on this could also note bug 243480. Maybe all the 4 icons could be updated.
Comment 2 :aceman 2012-02-23 14:22:53 PST
Andreas, I got a hint you could be the right person for this.
Comment 3 Andreas Nilsson (:andreasn) 2012-05-28 08:07:37 PDT
(In reply to :aceman from comment #2)
> Andreas, I got a hint you could be the right person for this.

Yes, new icons coming up!
Comment 4 Andreas Nilsson (:andreasn) 2012-05-28 10:00:08 PDT
Created attachment 627740 [details]
pinstripe mail-toolbar proposal

I'll upload a variant that takes bug 243480 into account as well shortly.
Comment 5 :aceman 2012-05-28 13:00:06 PDT
Bwinton, do you actually agree with bug 243480?
Comment 6 :aceman 2012-05-28 13:01:51 PDT
Andreas, I do not understand the proposal. Which are the new icons in the image?
Comment 7 Blake Winton (:bwinton) (:☕️) 2012-05-28 13:03:46 PDT
Yeah, the selection moves up and down, not left and right, so having previous and next go that way makes sense to me, too.
Comment 8 Andreas Nilsson (:andreasn) 2012-05-29 01:37:39 PDT
Created attachment 627880 [details]
pinstripe mail-toolbar proposal 2

And this version with the arrows pointing down. It's the two icons to the very right (the regular next&previous icons are also fixed).
Comment 9 :aceman 2012-05-29 01:40:44 PDT
Ok, thanks. What are those 2 joined bullets in the icons?
Comment 10 Andreas Nilsson (:andreasn) 2012-05-29 01:42:22 PDT
it's the same icon we use for "read"
Comment 11 Andreas Nilsson (:andreasn) 2012-05-29 01:46:13 PDT
if these are ok I'll do qute and gnomestripe as well.
Comment 12 :aceman 2012-05-29 02:07:19 PDT
Comment on attachment 627880 [details]
pinstripe mail-toolbar proposal 2

I do not have much opinion on how they should look like. I take anything.
I can only test the gnomestripe version.
Comment 13 Blake Winton (:bwinton) (:☕️) 2012-05-31 07:53:59 PDT
Comment on attachment 627880 [details]
pinstripe mail-toolbar proposal 2

Yeah, I like those…  ui-r=me!

Thanks,
Blake.
Comment 14 Blake Winton (:bwinton) (:☕️) 2012-05-31 08:12:50 PDT
Comment on attachment 627880 [details]
pinstripe mail-toolbar proposal 2

(I would be even cooler if I actually remembered to change the ui-review flag to + when I gave my ui-r+…  ;)
Comment 15 Andreas Nilsson (:andreasn) 2012-06-05 09:14:42 PDT
Created attachment 630189 [details] [diff] [review]
new icons for all platforms

Still needs css.
Comment 16 :aceman 2012-06-05 12:15:43 PDT
I can do the css if you wish.
Comment 17 Andreas Nilsson (:andreasn) 2012-06-07 09:02:19 PDT
Created attachment 631004 [details] [diff] [review]
icons+css

Need to actually try it in action on all platforms first, but I think this should do the trick.
Comment 18 Andreas Nilsson (:andreasn) 2012-06-08 08:40:07 PDT
Created attachment 631406 [details] [diff] [review]
icons+css v2

Had accidentally switched the numbers around for unread and regular next/previous. This also takes out the rtl variants, as the graphics now goes up and down.
Comment 19 :aceman 2012-06-08 08:47:21 PDT
Thanks, I'll try it out.
Comment 20 :aceman 2012-06-10 04:57:05 PDT
Comment on attachment 631406 [details] [diff] [review]
icons+css v2

Thanks! I can confirm the new icons work in Linux (gnomestripe), LTR setup, both normal and small toolbar and standalone message window.
Comment 21 Andreas Nilsson (:andreasn) 2012-06-11 04:52:34 PDT
Comment on attachment 631406 [details] [diff] [review]
icons+css v2

Setting up for review
Comment 22 Blake Winton (:bwinton) (:☕️) 2012-06-13 12:20:57 PDT
Comment on attachment 631406 [details] [diff] [review]
icons+css v2

Okay, I know this is totally a dick-move, but when I see the next-unread/previous-unread, I'm not really happy with the sunglasses (at least on OS X).  We aren't using them in the QFB, or in the message-list-header, so they seem odd and out-of-place.  What do you think about a double-up-arrow/double-down-arrow instead?  Or making them the same as the next/previous icons, like we do now?

Sorry about that,
Blake.
Comment 23 :aceman 2012-06-13 12:27:11 PDT
They should not be the same, the point of this bug is to distinguish them.
But making the prev/next be 1 arrow, and prev/next unread be 2 arrows was in the original proposal :)
Comment 24 Blake Winton (:bwinton) (:☕️) 2012-06-13 12:40:44 PDT
Yeah, I'm really sorry about that.  :(
Comment 25 Mike Conley (:mconley) - (needinfo me!) 2012-06-18 07:15:16 PDT
Comment on attachment 631406 [details] [diff] [review]
icons+css v2

Removing r? until the icons issue is resolved.
Comment 26 :aceman 2012-06-25 12:25:24 PDT
Created attachment 636439 [details]
icons proposal

So here is my proposal, based on gnomestripe theme. Rotate existing prev/next unread icons (double tip-of-an-arrow) and add new icons for prev/next read action (single tip-of-an-arrow). Other themes do not seem to use the white sheet behind the arrows, so adapt each theme as necessary (actually, copy existing double arrow and make single arrow version, and rotate both).

This is just a mockup, please align the arrows nicely in the final icons (so they can't be just 90deg rotations, there need to be some adjustments).
Comment 27 Blake Winton (:bwinton) (:☕️) 2012-06-25 13:34:49 PDT
Comment on attachment 636439 [details]
icons proposal

I think this works for me.  I'ld like to see what it would look like on the other platforms, too, but I understand if you can't do that, aceman…

Thanks,
Blake.
Comment 28 :aceman 2012-06-25 13:45:03 PDT
I could do it, but it is mostly the same. I just wanted to show both of you how the directions and double/single arrows are meant.
Comment 29 Andreas Nilsson (:andreasn) 2012-06-26 07:30:16 PDT
Comment on attachment 636439 [details]
icons proposal

I'm planning on dropping the sheets behind those icons, but apart from that, I agree with this plan.
Comment 30 Andreas Nilsson (:andreasn) 2012-06-26 08:45:09 PDT
Created attachment 636725 [details] [diff] [review]
new icons based on acemans sketch

Here are the new icons, replacing the files that bitrotted with the landing of #748358. Updated css coming shortly.
Comment 31 Andreas Nilsson (:andreasn) 2012-06-26 10:56:56 PDT
Created attachment 636784 [details] [diff] [review]
new icons, new css

Same as above, with some css. Badly formatted right now.
Comment 32 :aceman 2012-06-26 11:03:08 PDT
Comment on attachment 636784 [details] [diff] [review]
new icons, new css

Why did the css need change? Wasn't the previous version fine just the icons needed replacement?
Comment 33 Andreas Nilsson (:andreasn) 2012-06-26 11:06:00 PDT
It's the same css, just not bitrotted.
Comment 34 :aceman 2012-06-26 11:37:07 PDT
Comment on attachment 636784 [details] [diff] [review]
new icons, new css

Great, just tested the patch on gnomestripe and the icons are nice, as I proposed. Only I think you got them swapped in the css. The double arrow now does "next/prev read" instead of "next/prev unread" as before.
Comment 35 Andreas Nilsson (:andreasn) 2012-06-27 04:07:31 PDT
Created attachment 637068 [details] [diff] [review]
new icons and css (v3)
Comment 36 :aceman 2012-06-27 11:38:14 PDT
Comment on attachment 637068 [details] [diff] [review]
new icons and css (v3)

Thanks, this is what I had in mind.
Comment 37 Blake Winton (:bwinton) (:☕️) 2012-06-27 13:35:49 PDT
Comment on attachment 637068 [details] [diff] [review]
new icons and css (v3)

Awesome!  ui-r=me!

Later,
Blake.
Comment 38 :aceman 2012-06-27 13:43:45 PDT
The patch is just css and icon files. Who can review that?
Comment 39 Blake Winton (:bwinton) (:☕️) 2012-06-27 13:51:51 PDT
Comment on attachment 637068 [details] [diff] [review]
new icons and css (v3)

(In reply to :aceman from comment #38)
> The patch is just css and icon files. Who can review that?

Good question.  I can.  r=me.  :)

Later,
Blake.
Comment 40 Ryan VanderMeulen [:RyanVM] 2012-06-27 16:58:58 PDT
https://hg.mozilla.org/comm-central/rev/bcd212ed28fc
Comment 41 Thomas Sisson 2012-11-09 17:02:58 PST
In the default theme for Thunderbird 16.0.2 on Ubuntu 12.10, the next arrow points up until you put the mouse over it. Many themes that work well in the Linux such as Silvermel still do not have Previous and Next icons. Oxygenate, the perfect theme while using the KDE manager, is no longer compatible. Is there a way for all themes to fall back to a default icon if it is not defined in a theme? If there is, I think that this should be a requirement for all themes uploaded to Mozilla Add-ons. Themes, just as extensions, available at other websites would be downloaded and installed at the risk of the user for quality, functionality, and malicious code.
Comment 42 :aceman 2012-11-10 12:13:12 PST
The Ubuntu icon problem is bug 801514. Ubuntu uses a different theme than Thunderbird ships for Linux.

Note You need to log in before you can comment on or make changes to this bug.