Add a facility to capture played audio to WAV files for debugging

RESOLVED FIXED in mozilla23

Status

()

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
mozilla23
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Created attachment 597665 [details] [diff] [review]
possible patch

I found this tremendously useful while debugging, but this may not be the right long-term solution especially if/when we move away from nsBufferedAudioStream to use libcubeb directly. In which case we might want something at the libcubeb level, or directly in the GraphManager. Whatever you think.
Attachment #597665 - Flags: review?
Attachment #597665 - Flags: review? → review?(kinetik)
Comment on attachment 597665 [details] [diff] [review]
possible patch

Doing disk I/O from this callback seems like a very bad idea.  Do you need to be able to play the audio to real hardware and save it to disk at the same time?  If not, adding a Wave/raw PCM backend to cubeb would be once approach.  If you need playback and write out at the same time, the disk I/O needs to be moved out of the callback.
Attachment #597665 - Flags: review?(kinetik) → review-
It works for me while I'm debugging. There's no real need to land this I guess.
Duplicate of this bug: 857720
Attachment #597665 - Flags: review- → review+
Ehsan wants this too, so let's just land it.  My earlier objections were too fussy for something debug-only.
https://hg.mozilla.org/mozilla-central/rev/bdf9d4faddd9
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.